summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm35
1 files changed, 3 insertions, 32 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 750e3e93ce..5a2358f19a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gpodder)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -4009,36 +4010,6 @@ OSC connections.")
the electronic or dubstep genre.")
(license license:gpl3+)))
-(define-public libmygpo-qt
- (package
- (name "libmygpo-qt")
- (version "1.1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://stefan.derkits.at/files/"
- "libmygpo-qt/libmygpo-qt." version ".tar.gz"))
- (sha256
- (base32
- "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))
- (patches (search-patches "libmygpo-qt-fix-qt-5.11.patch"
- "libmygpo-qt-missing-qt5-modules.patch"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("qt" ,qtbase)))
- (arguments
- `(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
- ;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
- ;; is fixed.
- #:tests? #f))
- (home-page "http://wiki.gpodder.org/wiki/Libmygpo-qt")
- (synopsis "Qt/C++ library wrapping the gpodder web service")
- (description "@code{libmygpo-qt} is a Qt/C++ library wrapping the
-@url{https://gpodder.net} APIs. It allows applications to discover, manage
-and track podcasts.")
- (license license:lgpl2.1+)))
-
(define-public sonivox-eas
(package
(name "sonivox-eas")
@@ -4227,7 +4198,7 @@ compact disc (CDDA) identifiers.")
(define-public perl-webservice-musicbrainz
(package
(name "perl-webservice-musicbrainz")
- (version "1.0.4")
+ (version "1.0.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4235,7 +4206,7 @@ compact disc (CDDA) identifiers.")
version ".tar.gz"))
(sha256
(base32
- "182z3xjajk6s7k5xm3kssjy3hqx2qbnq4f8864hma098ryy2ph3a"))))
+ "16chs1l58cf000d5kalkyph3p31ci73p1rlyx98mfv10d2cq6fsj"))))
(build-system perl-build-system)
(arguments
;; Tests try to connect to http://musicbrainz.org.