summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm107
1 files changed, 100 insertions, 7 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2c3b2ff5ff..87497f6f66 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
@@ -423,7 +423,10 @@ many input formats and provides a customisable Vi-style user interface.")
"Clarinet in Bb.denemo"))
#t)))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for gtester
+ `(("intltool" ,intltool)
+ ("glib:bin" ,glib "bin") ; for gtester
+ ("gtk-doc" ,gtk-doc)
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -433,13 +436,10 @@ many input formats and provides a customisable Vi-style user interface.")
("fluidsynth" ,fluidsynth)
("glib" ,glib)
("gtk+" ,gtk+)
- ("gtk-doc" ,gtk-doc)
("gtksourceview" ,gtksourceview-3)
("guile" ,guile-2.0)
- ("intltool" ,intltool)
("librsvg" ,librsvg)
("libsndfile" ,libsndfile)
- ("libtool" ,libtool)
("libxml2" ,libxml2)
("lilypond" ,lilypond)
("portaudio" ,portaudio)
@@ -1128,6 +1128,40 @@ be used alone or in concert with Non Mixer and Non Sequencer to form a
complete studio.")
(license license:gpl2+)))
+(define-public bsequencer
+ (package
+ (name "bsequencer")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BSEQuencer.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08xwz5v8wrar0rx7qdr9pkpjz2k9sw6bn5glhpn6sp6453fabf8q"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("lv2" ,lv2)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/sjaehn/BSEQuencer")
+ (synopsis "Multi-channel MIDI step sequencer LV2 plugin")
+ (description
+ "This package provides a multi-channel MIDI step sequencer LV2 plugin
+with a selectable pattern matrix size.")
+ (license license:gpl3+)))
+
(define-public solfege
(package
(name "solfege")
@@ -3804,7 +3838,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "3.3.2")
+ (version "3.3.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3813,7 +3847,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(file-name (git-file-name name version))
(sha256
(base32
- "0r2xhhwv09v8ykgvh38fgpmpcmkra7lvhv7714xp7vb0wpcnh8l3"))
+ "11pcw2ihi7ddd4rr83y72i61yyc1qfj6v14a82zwlak2qnllpbmr"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.
@@ -5013,3 +5047,62 @@ Soul Force), MVerb, Nekobi, and ProM.")
MacArthur's AVLdrums. This plugin provides a convenient way to sequence and mix
MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(license license:gpl2+)))
+
+(define-public helm
+ (package
+ (name "helm")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mtytel/helm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "lv2" "standalone")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'include-pnglib-code-and-remove-usr-from-paths
+ (lambda _
+ (substitute* "standalone/builds/linux/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "builds/linux/LV2/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "Makefile"
+ (("/usr") ""))
+ #t))
+ (add-before 'reset-gzip-timestamps 'make-gz-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable
+ (find-files (string-append (assoc-ref outputs "out"))
+ ".*\\.gz$"))
+ #t))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("freetype2" ,freetype)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama", libxinerama)
+ ("jack", jack-1)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2", lv2)))
+ (home-page "https://tytel.org/helm/")
+ (synopsis "Polyphonic synth with lots of modulation")
+ (description "Helm is a cross-platform polyphonic synthesizer available standalone
+and as an LV2 plugin.")
+ (license license:gpl3+)))