summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ffba7c144c..2ae923d6ad 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -231,7 +231,7 @@
("pkg-config" ,pkg-config)))
(inputs
`(("dbus" ,dbus)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtmultimedia" ,qtmultimedia)
;; Plugin dependencies
("alsa-lib" ,alsa-lib)
@@ -434,7 +434,7 @@ score, keyboard, guitar, drum and controller views.")
("libxml2" ,libxml2)
("protobuf" ,protobuf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("sqlite" ,sqlite)
("sparsehash" ,sparsehash)
@@ -527,7 +527,7 @@ playing your music.")
("libmtp" ,libmtp)
("protobuf" ,protobuf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("sqlite" ,sqlite)
("taglib" ,taglib)))
@@ -759,7 +759,7 @@ settings (aliasing, linear interpolation and cubic interpolation).")
("libsndfile" ,libsndfile)
("lrdf" ,lrdf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtxmlpatterns" ,qtxmlpatterns)
("zlib" ,zlib)))
(home-page "http://www.hydrogen-music.org")
@@ -1990,7 +1990,7 @@ your own lessons.")
("boost" ,boost)
("minizip" ,minizip)
("pugixml" ,pugixml)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("rapidjson" ,rapidjson)
("rtmidi" ,rtmidi)
("timidity" ,timidity++)
@@ -2073,7 +2073,7 @@ users to select LV2 plugins and run them with jalv.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2106,7 +2106,7 @@ oscillators and stereo effects.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2139,7 +2139,7 @@ effects.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2172,7 +2172,7 @@ effects.")
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
("fftwf" ,fftwf)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2752,7 +2752,7 @@ browser.")
"/manpages/docbook.xsl")))
#t)))))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qttools" ,qttools)
("alsa-lib" ,alsa-lib)))
@@ -2800,7 +2800,7 @@ backends, including ALSA, OSS, Network and FluidSynth.")
#t)))))
(inputs
`(("drumstick" ,drumstick)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)))
(native-inputs
@@ -3140,7 +3140,7 @@ from the command line.")
(arguments
`(#:tests? #f)) ; no "check" target
(inputs
- `(("qt" ,qtbase)
+ `(("qt" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
@@ -4458,7 +4458,7 @@ develop custom plugins for use in other applications without programming.")
`(#:configure-flags
(list "--enable-qt5")))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
("liblo" ,liblo)
@@ -4489,7 +4489,7 @@ modules running in parallel.")
`(#:configure-flags
(list "--enable-qt5")))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("alsa-lib" ,alsa-lib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -4672,7 +4672,7 @@ are a C compiler and glib. Full API documentation and examples are included.")
"0g9pls46iggg7rdm65vzfj8nyr3v2n5xkp54c4qbh9hhalpsw4ay"))))))
(inputs
`(("sdl" ,sdl)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("fltk" ,fltk)
("libogg" ,libogg)
@@ -4777,7 +4777,7 @@ standalone JACK client and an LV2 plugin is also available.")
("portaudio" ,portaudio)
("portmidi" ,portmidi)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)
("qtquickcontrols2" ,qtquickcontrols2)
@@ -4855,7 +4855,7 @@ sample library.")
("lv2" ,lv2)
("pcre" ,pcre)
("pulseaudio" ,pulseaudio) ; required by rtaudio
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("rtaudio" ,rtaudio)
("rubberband" ,rubberband)
@@ -5047,7 +5047,7 @@ specification and header.")
("libsamplerate" ,libsamplerate)
("lilypond" ,lilypond)
("lrdf" ,lrdf)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("tar" ,tar)
("lirc" ,lirc)
("wavpack" ,wavpack)
@@ -5153,7 +5153,7 @@ the electronic or dubstep genre.")
`(("alsa-lib" ,alsa-lib)
("drumstick" ,drumstick)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://github.com/pedrolcl/Linux-SonivoxEas")
@@ -5537,7 +5537,7 @@ discard bad quality ones.
("fftw" ,fftw)
("jack" ,jack-1)
("portaudio" ,portaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtmultimedia" ,qtmultimedia)
("qtsvg" ,qtsvg)))
(native-inputs