summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1fb78c091f..2787ff0b00 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -21,7 +21,7 @@
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
-;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
+;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -2213,7 +2213,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.6.1")
+ (version "1.7.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/yoshimi/"
@@ -2221,7 +2221,7 @@ capabilities, custom envelopes, effects, etc.")
"/yoshimi-" version ".tar.bz2"))
(sha256
(base32
- "1shnz429zgl0b4y5bpb61frk1747jwqfahq4hx44c972580zghzh"))))
+ "1pkqrrr51vlxh96vy0c0rf5ijjvymys4brsw9rv1bdp1bb8izw6c"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -2999,7 +2999,7 @@ using the beets FetchArt plugin.")
module files. It attempts to recreate the module replay and user experience of
the popular DOS program Fasttracker II, with special playback modes available
for improved Amiga ProTracker 2/3 compatibility.")
- (home-page "http://milkytracker.titandemo.org/")
+ (home-page "https://milkytracker.titandemo.org/")
;; 'src/milkyplay' is under Modified BSD, the rest is under GPL3 or later.
(license (list license:bsd-3 license:gpl3+))))
@@ -3878,7 +3878,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "3.4.1")
+ (version "3.4.2")
(source
(origin
(method git-fetch)
@@ -3887,7 +3887,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "16rx4x0czhwjg8vppcc7iw0cvii9q2l730cqhmhvip9r8wwamsvj"))
+ (base32 "14a9sg87nx7xca1qfbkplnpbx9pyg9k9vy87dq0g401ag6g6bi66"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.
@@ -3927,6 +3927,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols2" ,qtquickcontrols2)
("qtscript" ,qtscript)
("qtsvg" ,qtsvg)
("qtxmlpatterns" ,qtxmlpatterns)))
@@ -5142,7 +5143,7 @@ and as an LV2 plugin.")
(define-public zrythm
(package
(name "zrythm")
- (version "0.7.345")
+ (version "0.7.474")
(source
(origin
(method url-fetch)
@@ -5150,13 +5151,21 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ "0qq9v8y27zhamcb7nq7pl76874ws8x8cxhp5r685b8binvl9p0az"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:configure-flags
`("-Denable_tests=true" "-Dmanpage=true"
- "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-xdg-open
+ (lambda _
+ (substitute* "src/utils/io.c"
+ (("OPEN_DIR_CMD")
+ (string-append "\"" (which "xdg-open") "\"")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)