summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm76
1 files changed, 39 insertions, 37 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index abbc60331f..73118f4c79 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2018 nee <nee.git@hidamari.blue>
;;; Copyright © 2018, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
@@ -635,7 +635,7 @@ many input formats and provides a customisable Vi-style user interface.")
;; Replace hard-coded diff file name.
(substitute* "tests/integration.c"
(("/usr/bin/diff")
- (string-append (assoc-ref inputs "diffutils") "/bin/diff")))
+ (search-input-file inputs "/bin/diff")))
;; Denemo's documentation says to use this command to run its
;; test suite.
(invoke "make" "-C" "tests" "check")))
@@ -643,8 +643,7 @@ many input formats and provides a customisable Vi-style user interface.")
;; This phase sets the default path for lilypond to its current
;; location in the store.
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((lilypond (string-append (assoc-ref inputs "lilypond")
- "/bin/lilypond")))
+ (let* ((lilypond (search-input-file inputs "/bin/lilypond")))
(substitute* "src/core/prefops.c"
(("g_string_new \\(\"lilypond\"\\);")
(string-append "g_string_new (\""
@@ -1453,23 +1452,22 @@ and auto-mapping slices to MIDI note numbers.")
"/share/fonts/opentype/"))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'use-texlive-union
- (lambda _
- ;; FIXME: fonts are not found and have to be generated in HOME.
- (setenv "HOME" "/tmp")
- ;; The test for the "lh" package fails, even though it is among
- ;; the inputs.
- (substitute* "configure"
- (("TEX_FIKPARM=.*") "TEX_FIKPARM=found\n"))
- #t))
(add-after 'unpack 'fix-path-references
(lambda _
(substitute* "scm/backend-library.scm"
(("\\(search-executable '\\(\"gs\"\\)\\)")
(string-append "\"" (which "gs") "\""))
(("\"/bin/sh\"")
- (string-append "\"" (which "sh") "\"")))
- #t))
+ (string-append "\"" (which "sh") "\"")))))
+ (add-after 'fix-path-references 'adjust-to-API-change
+ (lambda _
+ (substitute* '("Documentation/pictures/GNUmakefile"
+ "stepmake/stepmake/tex-rules.make")
+ ((".*-c .setpdfwrite.*") ""))
+ (substitute* "scm/backend-library.scm"
+ (("\"-c.setpdfwrite\"") ""))
+ (substitute* "scm/framework-ps.scm"
+ (("\".setpdfwrite ") "\""))))
(add-before 'configure 'prepare-configuration
(lambda _
(substitute* "configure"
@@ -1480,14 +1478,12 @@ and auto-mapping slices to MIDI note numbers.")
;; Also allow for SOURCE_DATE_EPOCH = 0 in fontforge.
(("20110222") "19700101"))
(setenv "out" "www")
- (setenv "conf" "www")
- #t))
+ (setenv "conf" "www")))
(add-after 'install 'install-info
(lambda _
(invoke "make"
"-j" (number->string (parallel-job-count))
- "conf=www" "install-info")
- #t)))))
+ "conf=www" "install-info"))))))
(inputs
`(("guile" ,guile-1.8)
("font-dejavu" ,font-dejavu)
@@ -1506,9 +1502,9 @@ and auto-mapping slices to MIDI note numbers.")
("gettext" ,gettext-minimal)
("imagemagick" ,imagemagick)
("netpbm" ,netpbm) ;for pngtopnm
- ("texlive" ,(texlive-union (list texlive-metapost
- texlive-generic-epsf
- texlive-latex-lh
+ ("texlive" ,(texlive-updmap.cfg (list texlive-metapost
+ texlive-epsf
+ texlive-lh
texlive-latex-cyrillic)))
("texinfo" ,texinfo)
("texi2html" ,texi2html-1.82)
@@ -1558,7 +1554,7 @@ Guile.")
("python-iniconfig" ,python-iniconfig)
("python-isort" ,python-isort)
("python-mypy" ,python-mypy)
- ("python-pytest" ,python-pytest-6)
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-sphinx-autodoc-typehints" ,python-sphinx-autodoc-typehints)))
(inputs
@@ -1613,7 +1609,7 @@ typographic detail of symbols on the page.")
("python-iniconfig" ,python-iniconfig)
("python-isort" ,python-isort)
("python-mypy" ,python-mypy)
- ("python-pytest" ,python-pytest-6)
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-helpers-namespace" ,python-pytest-helpers-namespace)))
(propagated-inputs
@@ -1655,7 +1651,7 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
("python-iniconfig" ,python-iniconfig)
("python-isort" ,python-isort)
("python-mypy" ,python-mypy)
- ("python-pytest" ,python-pytest-6)
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-helpers-namespace" ,python-pytest-helpers-namespace)))
(propagated-inputs
@@ -1702,7 +1698,7 @@ music theorist Paul Nauert's quantization grids or Q-Grids, for short.")
("python-iniconfig" ,python-iniconfig)
("python-isort" ,python-isort)
("python-mypy" ,python-mypy)
- ("python-pytest" ,python-pytest-6)
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-helpers-namespace" ,python-pytest-helpers-namespace)))
(propagated-inputs
@@ -1852,7 +1848,7 @@ complete studio.")
(build-system gnu-build-system)
(inputs
`(("liblo" ,liblo)
- ("gtkmm" ,gtkmm)
+ ("gtkmm" ,gtkmm-3)
("alsa-lib" ,alsa-lib)
("libxml++" ,libxml++-2)))
(native-inputs
@@ -2060,9 +2056,9 @@ for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'solfege' runs with the correct PYTHONPATH.
(let* ((out (assoc-ref outputs "out"))
- (path (getenv "PYTHONPATH")))
+ (path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/solfege")
- `("PYTHONPATH" ":" prefix (,path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,path))))
#t)))))
(inputs
`(("python" ,python-2)
@@ -3279,9 +3275,7 @@ can connect to any JACK port and record the output into a stereo WAV file.")
;; Fix reference to dlopened libraries.
(substitute* "jackselect/alsainfo.py"
(("libasound.so.2")
- (string-append (assoc-ref inputs "alsa-lib")
- "/lib/libasound.so.2")))
- #t))
+ (search-input-file inputs "/lib/libasound.so.2")))))
(replace 'build
(assoc-ref python:%standard-phases 'build))
(add-after 'install 'wrap
@@ -3465,7 +3459,13 @@ and hold, etc.")
"/include/"))
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'build 'target-specific-glib-API-version
+ (lambda _
+ ;; See https://github.com/brummer10/gxtuner/pull/21
+ (setenv "CFLAGS"
+ "-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_54\
+ -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_54"))))))
(inputs
`(("gtk+" ,gtk+)
("jack" ,jack-1)
@@ -3552,8 +3552,7 @@ socket or command line.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "curseradio/curseradio.py"
(("/usr/bin/mpv")
- (string-append (assoc-ref inputs "mpv") "/bin/mpv")))
- #t)))))
+ (search-input-file inputs "/bin/mpv"))))))))
(propagated-inputs
`(("python-lxml" ,python-lxml)
("python-requests" ,python-requests)
@@ -5485,6 +5484,10 @@ Recording Code} (ISRC) can be extracted.}")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "src/CMakeLists.txt"
+ (("\\*.inc") ""))))
(replace 'check
(lambda _
;; requires network connections
@@ -6431,7 +6434,6 @@ and as an LV2 plugin.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.55
#:configure-flags
`("-Dtests=true"
"-Dmanpage=true"
@@ -6904,7 +6906,7 @@ It is provided as an LV2 plugin and as a standalone Jack application.")
(substitute* (string-append bin "a2j")
(("a2j_control") (string-append bin "a2j_control")))
(wrap-program (string-append bin "a2j_control")
- `("PYTHONPATH" prefix (,(getenv "PYTHONPATH"))))
+ `("PYTHONPATH" prefix (,(getenv "GUIX_PYTHONPATH"))))
#t))))))
(build-system meson-build-system)
(inputs