summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 77711c90ff..0398e28eff 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -263,12 +263,11 @@ bind processes, and much more.")
(add-after 'unpack 'find-opensm-headers
(lambda* (#:key inputs #:allow-other-keys)
(setenv "C_INCLUDE_PATH"
- (string-append (assoc-ref inputs "opensm")
- "/include/infiniband"))
+ (search-input-directory inputs
+ "/include/infiniband"))
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (assoc-ref inputs "opensm")
- "/include/infiniband"))
- #t))
+ (search-input-directory inputs
+ "/include/infiniband"))))
(add-before 'build 'remove-absolute
(lambda _
;; Remove compiler absolute file names (OPAL_FC_ABSOLUTE
@@ -359,8 +358,7 @@ software vendors, application developers and computer science researchers.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "ompi/mpi/java/c/Makefile.in"
(("\\$\\(top_builddir\\)/ompi/lib@OMPI_LIBMPI_NAME@.la")
- (string-append (assoc-ref inputs "openmpi") "/lib/libmpi.la")))
- #t))
+ (search-input-file inputs "/lib/libmpi.la")))))
(add-after 'install 'strip-jar-timestamps
(assoc-ref ant:%standard-phases 'strip-jar-timestamps)))))))
(synopsis "Java bindings for MPI")))