summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5dfb26ae75..f34b08e4ca 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -153,7 +153,7 @@ bind processes, and much more.")
(define-public openmpi
(package
(name "openmpi")
- (version "1.10.7")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
@@ -162,16 +162,20 @@ bind processes, and much more.")
"/downloads/openmpi-" version ".tar.bz2"))
(sha256
(base32
- "142s1vny9gllkq336yafxayjgcirj2jv0ddabj879jgya7hyr2d0"))))
+ "0pbqrm5faf57nasy1s81wqivl7zvxmv8lzjh8hvb0f3qxv8m0d36"))))
(build-system gnu-build-system)
(inputs
`(("hwloc" ,hwloc "lib")
("gfortran" ,gfortran)
("libfabric" ,libfabric)
- ,@(match (%current-system)
- ((member (package-supported-systems psm))
- `(("psm" ,psm)))
- (_ `()))
+ ,@(if (and (not (%current-target-system))
+ (member (%current-system) (package-supported-systems psm)))
+ `(("psm" ,psm))
+ '())
+ ,@(if (and (not (%current-target-system))
+ (member (%current-system) (package-supported-systems psm2)))
+ `(("psm2" ,psm2))
+ '())
("rdma-core" ,rdma-core)
("valgrind" ,valgrind)))
(native-inputs
@@ -205,8 +209,8 @@ bind processes, and much more.")
(("_ABSOLUTE") ""))
;; Avoid valgrind (which pulls in gdb etc.).
(substitute*
- '("./ompi/mca/io/romio/src/io_romio_component.c")
- (("MCA_io_romio_COMPLETE_CONFIGURE_FLAGS")
+ '("./ompi/mca/io/romio314/src/io_romio314_component.c")
+ (("MCA_io_romio314_COMPLETE_CONFIGURE_FLAGS")
"\"[elided to reduce closure]\""))
#t))
(add-before 'build 'scrub-timestamps ;reproducibility