summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 7d46870c55..654d1e4edc 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -103,17 +103,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
"0fx9n6qmyb4ls17j7kl58i1ivg9wfx9zm9wyfnwzw7lcwdl56sqk"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Ddocumentation=true") ; the default is 'false'...
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'expand-C++-include-path
- ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((path "CPLUS_INCLUDE_PATH")
- (gcc (assoc-ref inputs "gcc"))
- (c++ (string-append gcc "/include/c++")))
- (setenv path (string-append c++ ":" (getenv path)))
- #t))))))
+ `(#:configure-flags '("-Ddocumentation=true"))) ;the default is 'false'...
(inputs `(("ao" ,ao)
("alsa-lib" ,alsa-lib)
("avahi" ,avahi)
@@ -135,10 +125,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("zlib" ,zlib)))
- ;; MPD > 0.21 requires > GCC 6
- (native-inputs `(("gcc" ,gcc-8)
- ("gcc-lib" ,gcc-8 "lib")
- ("pkg-config" ,pkg-config)
+ (native-inputs `(("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)))
;; Missing optional inputs:
;; libyajl