summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index e3133d788a..f5789487b5 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -428,22 +428,20 @@ format.")
(patches (search-patches "mpc123-initialize-ao.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda _
- (substitute* "Makefile"
- (("CC[[:blank:]]*:=.*")
- "CC := gcc\n")))
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (mkdir-p bin)
- (install-file "mpc123" bin)))
- %standard-phases))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("CC[[:blank:]]*:=.*")
+ "CC := gcc\n"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (install-file "mpc123" bin)))))
#:tests? #f))
-
(native-inputs
`(("gettext" ,gnu-gettext)))
(inputs