summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 3555958f2a..406d010193 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -412,7 +413,8 @@ command-line tool as well as a C library, libmpg123.")
(base32
"0ki8mh76bbmdh77qsiw682dvi8y468yhbdabqwg05igmwc1wqvq5"))
(patches
- (search-patches "mpg321-CVE-2019-14247.patch"))))
+ (search-patches "mpg321-CVE-2019-14247.patch"
+ "mpg321-gcc-10.patch"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-alsa")))
(inputs
@@ -481,7 +483,7 @@ use with CD-recording software).")
(patches (search-patches "ripperx-missing-file.patch"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("gs-fonts" ,gs-fonts)
+ `(("font-ghostscript" ,font-ghostscript)
("cdparanoia" ,cdparanoia)
("flac" ,flac)
("lame" ,lame)
@@ -544,7 +546,9 @@ format.")
(lambda _
(substitute* "Makefile"
(("CC[[:blank:]]*:=.*")
- "CC := gcc\n"))))
+ "CC := gcc\n"))
+
+ (setenv "CFLAGS" "-fcommon -g"))) ;allow compilation with GCC 10
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))