summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm85
1 files changed, 35 insertions, 50 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index f71daaee8a..b3e20760e2 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rrdtool)
@@ -86,7 +87,7 @@
#t))))
(build-system gnu-build-system)
(native-inputs
- `(("unzip" ,unzip)))
+ (list unzip))
(inputs
`(("zlib" ,zlib)
("libpng-apng" ,libpng)
@@ -181,8 +182,7 @@ etc. via a Web interface. Features include:
(string-append "--with-libpcre="
(assoc-ref %build-inputs "pcre")))))
(inputs
- `(("libiconv" ,libiconv)
- ("pcre" ,pcre)))
+ (list libiconv pcre))
(home-page "https://www.zabbix.com/")
(synopsis "Distributed monitoring solution (client-side agent)")
(description "This package provides a distributed monitoring
@@ -235,14 +235,14 @@ solution (client-side agent)")
(assoc-ref %build-inputs "zlib"))
,flags))))
(inputs
- `(("curl" ,curl)
- ("libevent" ,libevent)
- ("gnutls" ,gnutls)
- ("postgresql" ,postgresql)
- ("zlib" ,zlib)
- ("net-snmp" ,net-snmp)
- ("curl" ,curl)
- ,@(package-inputs zabbix-agentd)))
+ (modify-inputs (package-inputs zabbix-agentd)
+ (prepend curl
+ libevent
+ gnutls
+ postgresql
+ zlib
+ net-snmp
+ curl)))
(synopsis "Distributed monitoring solution (server-side)")
(description "This package provides a distributed monitoring
solution (server-side)")))
@@ -313,11 +313,10 @@ through a text-based interface.")
(invoke "python" "setup.py" "nosetests")
(format #t "test suite not run~")))))))
(native-inputs
- `(;; For tests.
- ("python-httpretty" ,python-httpretty)
- ("python-nose" ,python-nose)))
+ (list ;; For tests.
+ python-httpretty python-nose))
(propagated-inputs
- `(("python-requests" ,python-requests)))
+ (list python-requests))
(synopsis "Python interface to the Zabbix API")
(description
"@code{pyzabbix} is a Python module for working with the Zabbix API.")
@@ -337,8 +336,7 @@ through a text-based interface.")
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no tests
(inputs
- `(("libpcap" ,libpcap)
- ("zlib" ,zlib)))
+ (list libpcap zlib))
(home-page "https://unix4lyfe.org/darkstat/")
(synopsis "Network statistics gatherer")
(description
@@ -358,15 +356,16 @@ HTTP. Features:
(define-public python-whisper
(package
(name "python-whisper")
- (version "1.0.2")
+ (version "1.1.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "whisper" version))
(sha256
(base32
- "1v1bi3fl1i6p4z4ki692bykrkw6907dn3mfq0151f70lvi3zpns3"))))
+ "1bk29w09zcpsv8hp0g0al7nwrxa07z0ycls3mbh83wfavk83aprl"))))
(build-system python-build-system)
+ (native-inputs (list python-six))
(home-page "http://graphiteapp.org/")
(synopsis "Fixed size round-robin style database for Graphite")
(description "Whisper is one of three components within the Graphite
@@ -396,10 +395,7 @@ historical data.")
(add-after 'unpack 'do-not-install-to-/opt
(lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
(propagated-inputs
- `(("python-cachetools" ,python-cachetools)
- ("python-txamqp" ,python-txamqp)
- ("python-urllib3" ,python-urllib3)
- ("python-whisper" ,python-whisper)))
+ (list python-cachetools python-txamqp python-urllib3 python-whisper))
(home-page "http://graphiteapp.org/")
(synopsis "Backend data caching and persistence daemon for Graphite")
(description "Carbon is a backend data caching and persistence daemon for
@@ -435,15 +431,15 @@ and persisting them to disk using the Whisper time-series library.")
(add-after 'unpack 'do-not-install-to-/opt
(lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
(propagated-inputs
- `(("python-cairocffi" ,python-cairocffi)
- ("python-pytz" ,python-pytz)
- ("python-whisper" ,python-whisper)
- ("python-django" ,python-django-2.2)
- ("python-django-tagging" ,python-django-tagging)
- ("python-scandir" ,python-scandir)
- ("python-urllib3" ,python-urllib3)
- ("python-pyparsing" ,python-pyparsing)
- ("python-txamqp" ,python-txamqp)))
+ (list python-cairocffi
+ python-pytz
+ python-whisper
+ python-django-2.2
+ python-django-tagging
+ python-scandir
+ python-urllib3
+ python-pyparsing
+ python-txamqp))
(home-page "https://graphiteapp.org/")
(synopsis "Scalable realtime graphing system")
(description "Graphite is a scalable real-time graphing system that does
@@ -466,7 +462,7 @@ demand.")
'(;; No included tests.
#:tests? #f))
(propagated-inputs
- `(("python-twisted" ,python-twisted)))
+ (list python-twisted))
(home-page
"https://github.com/prometheus/client_python")
(synopsis "Python client for the Prometheus monitoring system")
@@ -535,12 +531,9 @@ written in Go with pluggable metric collectors.")
"/lib/udev/rules.d"))
#t)))))
(inputs
- `(("python-prometheus-client" ,python-prometheus-client)
- ("python-pyudev" ,python-pyudev)))
+ (list python-prometheus-client python-pyudev))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-pytest-mock" ,python-pytest-mock)
- ("python-pytest-runner" ,python-pytest-runner)))
+ (list python-pytest python-pytest-mock python-pytest-runner))
(home-page "https://github.com/yrro/temper-exporter")
(synopsis "Prometheus exporter for PCSensor TEMPer sensor devices")
(description
@@ -563,10 +556,7 @@ devices.")
"1yz65jsbgdx4cmy16x24wz5di352lvyi7fp6jm90bhgl1vpzxlsx"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("libtool" ,libtool)))
+ (list autoconf automake gettext-minimal libtool))
(synopsis "File system monitor")
(description "This package provides a file system monitor.")
(home-page "https://github.com/emcrisostomo/fswatch")
@@ -595,14 +585,9 @@ devices.")
;; Required because of patched sources.
(invoke "autoreconf" "-vfi"))))))
(inputs
- `(("rrdtool" ,rrdtool)
- ("curl" ,curl)
- ("libyajl" ,libyajl)))
+ (list rrdtool curl libyajl))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(home-page "https://collectd.org/")
(synopsis "Collect system and application performance metrics periodically")
(description
@@ -628,7 +613,7 @@ future system load (i.e., capacity planning).")
(base32
"0jw6yij8va0f292g4xkf9lp9sxkzfgv67ajw49g3vq42q47ld7cv"))))
(build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
+ (inputs (list ncurses))
(arguments '(#:tests? #f)) ;; No included tests.
(home-page "http://www.maier-komor.de/hostscope.html")
(properties `((release-monitoring-url . ,home-page)))