summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9f4134362a..c2ebcf7d18 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
@@ -320,9 +320,7 @@ user interfaces in a fast and easy way. It is based on GLib and ncurses.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "protobufgen.sh"
(("/bin/sh")
- (string-append (assoc-ref inputs "bash")
- "/bin/sh")))
- #t)))))
+ (search-input-file inputs "/bin/sh"))))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -829,7 +827,8 @@ used by Pidgin and Bitlbee, among others, to access
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(wrap-program (string-append bin "/hexchat")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH"))))))))))
(synopsis "Graphical IRC client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main
@@ -1199,7 +1198,7 @@ of xmpppy.")
"share/gajim/plugins")))
;; Gajim needs to use the propagated inputs of its plugins.
(search-path-specification
- (variable "PYTHONPATH")
+ (variable "GUIX_PYTHONPATH")
(files
(list
(string-append
@@ -1372,7 +1371,7 @@ Encryption to Gajim.")
;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
@@ -1388,7 +1387,7 @@ Encryption to Gajim.")
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal-2)
;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
@@ -1646,8 +1645,7 @@ messenger protocol.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "../source/src/xlib/gtk.c"
(("libgtk-3.so")
- (string-append (assoc-ref inputs "gtk+")
- "/lib/libgtk-3.so")))))
+ (search-input-file inputs "/lib/libgtk-3.so")))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -2007,7 +2005,9 @@ support, and more.")
"1rmrn7a1bb7vm26yaklrvx008a9qhwc32s57dwrlf40lv9gffwny"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "CFLAGS=-fcommon")
+ #:phases
(modify-phases %standard-phases
;; For 'system' commands in Scheme code.
(add-after 'install 'wrap-program