summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6a84f43bad..825d2b0828 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
@@ -312,18 +312,17 @@ user interfaces in a fast and easy way. It is based on GLib and ncurses.")
(base32 "1s16cripy5w9k12534qb012iwc5m9qcjyrywgsziyn3kl3i0aa8h"))))
(build-system gnu-build-system)
(arguments
+ ;; 'test/manual/userconfig.h' contains definitions in lieu of
+ ;; declarations, hence '-fcommon'.
`(#:configure-flags
- (list
- "--disable-static")
+ (list "--disable-static" "CFLAGS=-O2 -g -fcommon")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-shebangs
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "protobufgen.sh"
(("/bin/sh")
- (string-append (assoc-ref inputs "bash")
- "/bin/sh")))
- #t)))))
+ (search-input-file inputs "/bin/sh"))))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -871,7 +870,8 @@ used by Pidgin and Bitlbee, among others, to access
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(wrap-program (string-append bin "/hexchat")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH"))))))))))
(synopsis "Graphical IRC client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main
@@ -1241,7 +1241,7 @@ of xmpppy.")
"share/gajim/plugins")))
;; Gajim needs to use the propagated inputs of its plugins.
(search-path-specification
- (variable "PYTHONPATH")
+ (variable "GUIX_PYTHONPATH")
(files
(list
(string-append
@@ -1414,7 +1414,7 @@ Encryption to Gajim.")
;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
@@ -1430,7 +1430,7 @@ Encryption to Gajim.")
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal-2)
;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
@@ -1688,8 +1688,7 @@ messenger protocol.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "../source/src/xlib/gtk.c"
(("libgtk-3.so")
- (string-append (assoc-ref inputs "gtk+")
- "/lib/libgtk-3.so")))))
+ (search-input-file inputs "/lib/libgtk-3.so")))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -2049,7 +2048,9 @@ support, and more.")
"1rmrn7a1bb7vm26yaklrvx008a9qhwc32s57dwrlf40lv9gffwny"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "CFLAGS=-fcommon")
+ #:phases
(modify-phases %standard-phases
;; For 'system' commands in Scheme code.
(add-after 'install 'wrap-program
@@ -3051,18 +3052,14 @@ designed for experienced users.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'cd-to-zulip-dir
- (lambda _
- (chdir "zulip")
- #t))
+ (lambda _ (chdir "zulip")))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(let ((test-zulip "../tools/test-zulip"))
(when tests?
(add-installed-pythonpath inputs outputs)
- (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH")))
(patch-shebang test-zulip)
- (invoke test-zulip))
- #t))))))
+ (invoke test-zulip))))))))
(propagated-inputs
`(("python-matrix-client" ,python-matrix-client)
("python-pyopenssl" ,python-pyopenssl)
@@ -3201,7 +3198,7 @@ API. Mattermost is not required.")
"import sys\n"
(map (lambda (path)
(string-append "sys.path.append('" path "')\n"))
- (string-split (getenv "PYTHONPATH") #\:)))))
+ (string-split (getenv "GUIX_PYTHONPATH") #\:)))))
;; Install script.
(mkdir-p weechat-python)
(copy-file "main.py"
@@ -3251,7 +3248,7 @@ Weechat communicate over the Matrix protocol.")
all
(map (lambda (path)
(string-append "sys.path.append('" path "')\n"))
- (string-split (getenv "PYTHONPATH") #\:)))))
+ (string-split (getenv "GUIX_PYTHONPATH") #\:)))))
;; Install script.
(install-file "wee_slack.py"
(string-append (assoc-ref outputs "out")