summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm96
1 files changed, 52 insertions, 44 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f8bb673734..5e2a39fece 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mason Hock <chaosmonk@riseup.net>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -350,49 +351,53 @@ access to servers running the Discord protocol.")
(license license:gpl2+)))
(define-public purple-mattermost
- (package
- (name "purple-mattermost")
- (version "1.2")
- (home-page "https://github.com/EionRobb/purple-mattermost")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fm49iv58l09qpy8vkca3am642fxiwcrrh6ykimyc2mas210b5g2"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Adjust the makefile to install files in the right
- ;; place.
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile"
- (("MATTERMOST_DEST = .*")
- (string-append "MATTERMOST_DEST = " out
- "/lib/purple-2\n")) ;XXX: hardcoded
- (("MATTERMOST_ICONS_DEST = .*")
- (string-append "MATTERMOST_ICONS_DEST = "
- out
- "/share/pixmaps/pidgin/protocols\n")))
- #t))))
- #:make-flags (list "CC=gcc"
- ,(string-append "PLUGIN_VERSION=" version))
- #:tests? #f))
- (inputs `(("glib" ,glib)
- ("json-glib" ,json-glib)
- ("discount" ,discount)
- ("pidgin" ,pidgin)))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (synopsis "Purple plug-in to access Mattermost instant messaging")
- (description
- "Purple-Mattermost is a plug-in for Purple, the instant messaging library
+ ;; The latest release (1.2) only supports Mattermost's /api/v3. Choose a
+ ;; commit that supports /api/v4.
+ (let ((commit "158ce2052af9aaf3d1f6f045f0cfba276e0e91cf")
+ (revision "0"))
+ (package
+ (name "purple-mattermost")
+ (version (git-version "1.2" revision commit))
+ (home-page "https://github.com/EionRobb/purple-mattermost")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1481zm20pnfq52ncg7hxayjq8cw3a6yh9m4jm1m5s8chsq04015l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Adjust the makefile to install files in the right
+ ;; place.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("MATTERMOST_DEST = .*")
+ (string-append "MATTERMOST_DEST = " out
+ "/lib/purple-2\n")) ;XXX: hardcoded
+ (("MATTERMOST_ICONS_DEST = .*")
+ (string-append "MATTERMOST_ICONS_DEST = "
+ out
+ "/share/pixmaps/pidgin/protocols\n")))
+ #t))))
+ #:make-flags (list "CC=gcc"
+ ,(string-append "PLUGIN_VERSION=" version))
+ #:tests? #f))
+ (inputs `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("discount" ,discount)
+ ("pidgin" ,pidgin)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Purple plug-in to access Mattermost instant messaging")
+ (description
+ "Purple-Mattermost is a plug-in for Purple, the instant messaging library
used by Pidgin and Bitlbee, among others, to access
@uref{https://mattermost.com/, Mattermost} servers.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public hexchat
(package
@@ -536,7 +541,7 @@ authentication.")
(build-system glib-or-gtk-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("check" ,check)
+ ("check" ,check-0.14)
("intltool" ,intltool)
("gconf" ,gconf)
("python" ,python-2)
@@ -874,6 +879,7 @@ on Axolotl and PEP.")
(package
(name "dino")
(version "0.1.0")
+ (outputs '("out" "debug"))
(source
(origin
(method url-fetch)
@@ -2070,6 +2076,7 @@ There is support for:
(package
(name "quaternion")
(version "0.0.9.4e")
+ (outputs '("out" "debug"))
(source
(origin
(method git-fetch)
@@ -2313,7 +2320,7 @@ support for high performance Telegram Bot creation.")
(define-public chatty
(package
(name "chatty")
- (version "0.1.10")
+ (version "0.1.16")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2322,7 +2329,7 @@ support for high performance Telegram Bot creation.")
(file-name (git-file-name name version))
(sha256
(base32
- "0czvqwjzsb0rvmgrmbh97m1b35rnwl41j7q32z4fcqb7bschibql"))))
+ "085hb3ii1cy0jb3f0mim25v5r5w3gpfsdpjid5dmrpw4gi88aa2x"))))
(build-system meson-build-system)
(arguments
'(#:phases
@@ -2339,6 +2346,7 @@ support for high performance Telegram Bot creation.")
(inputs
`(("feedbackd" ,feedbackd)
("folks" ,folks)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libhandy" ,libhandy-0.0)