summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm62
1 files changed, 25 insertions, 37 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7d036ad473..503781a9eb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
@@ -490,56 +491,43 @@ compromised.")
(define-public znc
(package
(name "znc")
- (version "1.7.3")
+ (version "1.7.4")
(source (origin
(method url-fetch)
(uri (string-append "http://znc.in/releases/archive/znc-"
version ".tar.gz"))
(sha256
(base32
- "0g8i5hsl4kinpz1wp0a2zniidv3w2sd6awq8676fds516wcc6k0y"))))
- ;; TODO: autotools support has been deprecated, and new features like i18n
- ;; are only supported when building with cmake.
- (build-system gnu-build-system)
+ "0wcvqkpin8w4i72alnn0nxnrc9ih543qs34hqpk9xmz6m0hjk8xi"))))
+ (build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "-DWANT_CYRUS=ON"
+ "-DWANT_I18N=ON"
+ "-DWANT_PERL=ON"
+ "-DWANT_PYTHON=ON")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-googletest
+ ;; Copy the googletest sources to where the CMake build expects them.
(lambda* (#:key inputs #:allow-other-keys)
- (mkdir-p "googletest")
- (copy-recursively (assoc-ref inputs "googletest-source")
- "googletest")
- #t)))
- #:configure-flags '("--enable-python"
- "--enable-perl"
- "--enable-cyrus"
- "--with-gmock=googletest/googlemock"
- "--with-gtest=googletest/googletest")
- #:test-target "test"))
+ (let ((source (assoc-ref inputs "googletest-source"))
+ (target "third_party/googletest"))
+ (mkdir-p target)
+ (copy-recursively source target)
+ #t))))))
(native-inputs
- `(("googletest-source"
- ;; ZNC 1.7 needs a newer, unreleased googletest (a release is planned
- ;; <https://github.com/google/googletest/issues/1583>, so don't update
- ;; the public GOOGLETEST to an unstable version). The commit is taken
- ;; from ‘third_party/googletest’ in the ZNC git repository.
- ,(let ((commit "9737e63c69e94ac5777caa0bc77c77d5206467f3"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/googletest")
- (commit commit)))
- (file-name (git-file-name "googletest-for-znc" commit))
- (sha256
- (base32
- "0ya36n8d62zbxk6p22yffgx43mqhx2fz41gqqwbpdshjryf3wvxj")))))
- ("pkg-config" ,pkg-config)
- ("perl" ,perl)
- ("python" ,python)))
+ `(("boost" ,boost)
+ ("gettext" ,gettext-minimal)
+ ("googletest-source" ,(package-source googletest))
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("openssl" ,openssl)
- ("zlib" ,zlib)
+ `(("cyrus-sasl" ,cyrus-sasl)
("icu4c" ,icu4c)
- ("cyrus-sasl" ,cyrus-sasl)))
+ ("openssl" ,openssl)
+ ("perl" ,perl)
+ ("python" ,python)
+ ("zlib" ,zlib)))
(home-page "https://znc.in")
(synopsis "IRC network bouncer")
(description "ZNC is an @dfn{IRC network bouncer} or @dfn{BNC}. It can