summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 22e1c370aa..55c12c8e9a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -592,20 +592,17 @@ identi.ca and status.net).")
(base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--with-bdatadir=" out "/share/bitlbee/")
+ (string-append "--with-plugindir=" out "/lib/bitlbee/")))
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-autogen
(lambda _
(let ((sh (which "sh")))
(substitute* "autogen.sh" (("/bin/sh") sh))
- (setenv "CONFIG_SHELL" sh))
- #t))
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "./configure"
- (string-append "--with-plugindir="
- (assoc-ref outputs "out")
- "/lib/bitlbee/")))))))
+ (setenv "CONFIG_SHELL" sh)))))))
(inputs `(("glib" ,glib)))
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)