summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2d6a5c72d3..1876c3813c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -85,6 +85,7 @@
#:use-module (gnu packages kerberos)
#:use-module (gnu packages less)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libreoffice)
#:use-module (gnu packages linux)
@@ -707,15 +708,14 @@ used by Pidgin and Bitlbee, among others, to access
(define-public hexchat
(package
(name "hexchat")
- (version "2.14.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
- version ".tar.xz"))
- (patches (search-patches "hexchat-add-libera-chat.patch"))
- (sha256
- (base32
- "10p829jm1r6kidkgf5lhqhyqc5mxdcq96q3zhadsckasvc9rs6lh"))))
+ (version "2.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0dnwhb2gi08i5v79vq0y2izs89wyk3by96jv99kgkidjic3k2bj1"))))
(build-system meson-build-system)
(native-inputs `(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ;need glib-genmarshal
@@ -726,14 +726,16 @@ used by Pidgin and Bitlbee, among others, to access
("enchant" ,enchant)
("gtk" ,gtk+-2)
("libcanberra" ,libcanberra)
- ("libnotify" ,libnotify)
- ("libproxy" ,libproxy)
("openssl" ,openssl)
;; Bindings for add-on scripts.
("luajit" ,luajit)
("perl-xml-parser" ,perl-xml-parser)
- ("python-2" ,python-2)))
+ ("python" ,python)
+ ("python-cffi" ,python-cffi)
+
+ ;; For the ensuing WRAP-PROGRAM.
+ ("bash-minimal" ,bash-minimal)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -745,8 +747,14 @@ used by Pidgin and Bitlbee, among others, to access
;; just skip this code.
(substitute* "meson_post_install.py"
(("if 'DESTDIR' not in os.environ:")
- "if False:"))
- #t)))))
+ "if False:"))))
+ (add-after 'install 'wrap-program
+ ;; Let it ‘initialize the Python-CFFI embedding logic’ at run time.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (wrap-program (string-append bin "/hexchat")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
(synopsis "Graphical IRC client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main