summaryrefslogtreecommitdiff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index 84af3a1c53..8df4d9710b 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +20,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system ant)
@@ -321,14 +322,15 @@ other projects as their parent pom.")
(base32
"0yl2hbwz2kn1hll1i00ddzn8f89bfdcjwdifz0pj2j15k1gjch7v"))))
(arguments
- `(#:tests? #f
+ (list
+ #:tests? #f
#:phases
- (modify-phases %standard-phases
- (delete 'unpack)
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (install-pom-file (assoc-ref %build-inputs "source")))))))))
+ #~(modify-phases %standard-phases
+ (delete 'unpack)
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (install-pom-file #$(package-source this-package)))))))))
(define* (make-plexus-parent-pom version hash #:optional parent)
(hidden-package
@@ -516,14 +518,15 @@ tool. This package contains the Maven parent POM.")
"11skhrjgrrs6z5rw1w39ap1pzhrc99g0czip10kz7wsavg746ibm"))))
(build-system ant-build-system)
(arguments
- `(#:tests? #f
+ (list
+ #:tests? #f
#:phases
- (modify-phases %standard-phases
- (delete 'unpack)
- (delete 'build)
- (delete 'configure)
- (replace 'install
- (install-pom-file (assoc-ref %build-inputs "source"))))))
+ #~(modify-phases %standard-phases
+ (delete 'unpack)
+ (delete 'build)
+ (delete 'configure)
+ (replace 'install
+ (install-pom-file #$(package-source this-package))))))
(propagated-inputs
`(("maven-parent-pom-27" ,maven-parent-pom-27)))
(home-page "https://apache.org/maven")