summaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index e2c27f5a4c..5f94eb2075 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,8 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +26,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -257,25 +260,28 @@ fledged batteries-included asyncio layer using aiohttp.")
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "tests"))))
- ;; XXX: The sanity check trips on optional GUI libraries for the
- ;; panctl command.
- (delete 'sanity-check))))
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-pytest python-faker python-pytest-aiohttp
- python-aioresponses))
+ (list python-aioresponses
+ python-faker
+ python-pytest
+ python-pytest-aiohttp))
(propagated-inputs
(list python-aiohttp
python-appdirs
python-attrs
python-cachetools
python-click
+ python-dbus
python-janus
python-keyring
python-logbook
python-matrix-nio
+ python-notify2
python-peewee
- python-prompt-toolkit))
+ python-prompt-toolkit
+ python-pydbus
+ python-pygobject))
(home-page "https://github.com/matrix-org/pantalaimon")
(synopsis "Matrix proxy daemon that adds E2E encryption capabilities")
(description