summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 54ea2af515..e2eed7ecb3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4463,7 +4463,7 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.18")
+ (version "0.3.20")
(source
(origin
(method git-fetch)
@@ -4473,7 +4473,7 @@ parts of it.")
(file-name (git-file-name name version))
(sha256
(base32
- "17zdd8asylz2w71hczrz5y344p6d5ds1jn4901maw7zcp3dbk63g"))))
+ "0r4sz3rn68fyc2paq0a04pgfi7iszpm95f6ggbzxpvjzx9qxbcql"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -4532,14 +4532,14 @@ parts of it.")
(lambda* (#:key inputs #:allow-other-keys)
;; Get libgfortran found when building in utest.
(setenv "FEXTRALIB"
- (string-append "-L" (assoc-ref inputs "fortran-lib")
- "/lib")))))))
+ (string-append
+ "-L"
+ (dirname
+ (search-input-file inputs "/lib/libgfortran.so")))))))))
(inputs
- `(("fortran-lib" ,gfortran "lib")))
+ (list `(,gfortran "lib")))
(native-inputs
- `(("cunit" ,cunit)
- ("fortran" ,gfortran)
- ("perl" ,perl)))
+ (list cunit gfortran perl))
(home-page "https://www.openblas.net/")
(synopsis "Optimized BLAS library based on GotoBLAS")
(description