summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 46e5d3a5d0..83f0a1810b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1724,7 +1724,18 @@ HDF5 file is encoded according to the HDF File Format Specification.")
(base32
"14ddy2xnb6sgp4hiax9v5sv4pr4l4dd4ps76nfha3nrpr1ikhcqm"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; Tests require googletest *sources*
+ (arguments `(#:tests? #f ; Tests require googletest *sources*
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-man-page-date
+ (lambda _
+ (substitute* "itpp-config.1.cmake.in"
+ ((".PACKAGE_DATE.") "2012-04-18"))))
+ (add-before 'build 'set-force-source-date
+ ;; for reproducible dates, texlive needs this to respect respect
+ ;; SOURCE_DATE_EPOCH
+ (lambda _
+ (setenv "FORCE_SOURCE_DATE" "1"))))))
(inputs (list lapack fftw))
;; FIXME: Even though the fonts are available dvips complains:
;; "Font cmmi10 not found; characters will be left blank."