summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1ed1e0511b..1c02a1ab0f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1183,7 +1184,7 @@ extremely large and complex data collections.")
(define-public hdf5-1.10
(package/inherit hdf5-1.8
- (version "1.10.6")
+ (version "1.10.7")
(source
(origin
(method url-fetch)
@@ -1197,7 +1198,7 @@ extremely large and complex data collections.")
(take (string-split version #\.) 2))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "1gf38x51128hn00744358w27xgzjk0ff4wra4yxh2lk804ck1mh9"))
+ (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
(patches (search-patches "hdf5-config-date.patch"))))))
(define-public hdf5
@@ -2156,7 +2157,7 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
(define-public gmsh
(package
(name "gmsh")
- (version "2.16.0")
+ (version "4.6.0")
(source
(origin
(method git-fetch)
@@ -2168,12 +2169,11 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
version)))))
(file-name (git-file-name name version))
(sha256
- (base32 "08rq4jajwmlpivnm9yifz2jhaivnz065lnk0h2zv773nwl9wf162"))
+ (base32 "0m0pjxcy1bnr7a20i11lh0ih159pphq9wsvfjr3sfx4y3lginz5y"))
(modules '((guix build utils)))
(snippet
- ;; Remove non-free METIS code
'(begin
- (delete-file-recursively "contrib/Metis")
+ (delete-file-recursively "contrib/metis")
#t))))
(build-system cmake-build-system)
(propagated-inputs
@@ -2184,14 +2184,15 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
("lapack" ,lapack)
("mesa" ,mesa)
("glu" ,glu)
- ("opencascade-oce" ,opencascade-oce)
+ ("metis" ,metis)
+ ("opencascade-occt" ,opencascade-occt)
("libx11" ,libx11)
("libxext" ,libxext)))
(inputs
`(("fontconfig" ,fontconfig)
("libxft" ,libxft)))
(arguments
- `(#:configure-flags `("-DENABLE_METIS:BOOL=OFF"
+ `(#:configure-flags `("-DENABLE_SYSTEM_CONTRIB:BOOL=ON"
"-DENABLE_BUILD_SHARED:BOOL=ON"
"-DENABLE_BUILD_DYNAMIC:BOOL=ON")))
(home-page "http://gmsh.info/")
@@ -3863,7 +3864,7 @@ Fresnel integrals, and similar related functions as well.")
(define-public suitesparse
(package
(name "suitesparse")
- (version "5.7.1")
+ (version "5.8.1")
(source
(origin
(method git-fetch)
@@ -3873,7 +3874,7 @@ Fresnel integrals, and similar related functions as well.")
(file-name (git-file-name name version))
(sha256
(base32
- "174p3l78kv9gaa0i5hflyai2ydwnjzh34k9938sl4aa3li0543s8"))
+ "0qjlyfxs8s48rs63c2fzspisgq1kk4bwkgnhmh125hgkdhrq2w1c"))
(patches (search-patches "suitesparse-mongoose-cmake.patch"))
(modules '((guix build utils)))
(snippet
@@ -3886,7 +3887,6 @@ Fresnel integrals, and similar related functions as well.")
'(#:tests? #f ;no "check" target
#:make-flags
(list "CC=gcc"
- "BLAS=-lblas"
"TBB=-ltbb"
"MY_METIS_LIB=-lmetis"
;; Flags for cmake (required to build GraphBLAS and Mongoose)
@@ -3908,6 +3908,8 @@ Fresnel integrals, and similar related functions as well.")
(inputs
`(("tbb" ,tbb)
("lapack" ,lapack)
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)
("metis" ,metis)))
(native-inputs
`(("cmake" ,cmake-minimal)
@@ -5765,10 +5767,10 @@ compiled against the nauty library.")
"1j5aji1g2vmdvc0gqz45n2ll2l2f6czca04wiyfl5g3sm3a6vhvb"))))
(build-system gnu-build-system)
(native-inputs
- `(("m4", m4)))
+ `(("m4" ,m4)))
(inputs
`(("glpk" ,glpk)
- ("gmp", gmp)))
+ ("gmp" ,gmp)))
(home-page "https://www.bugseng.com/parma-polyhedra-library")
(synopsis
"Parma Polyhedra Library for computations with polyhedra")