summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm121
1 files changed, 96 insertions, 25 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 125edbea40..4019c7efaf 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2018, 2020 Kei Kebreau <kkebreau@posteo.net>
@@ -521,7 +521,7 @@ numbers.")
(define-public sleef
(package
(name "sleef")
- (version "3.4.1")
+ (version "3.5.1")
(source
(origin
(method git-fetch)
@@ -530,7 +530,7 @@ numbers.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1gvf7cfvszmgjrsqivwmyy1jnp3hy80dmszxx827lhjz8yqq5019"))))
+ (base32 "1jybqrl2dvjxzg30xrhh847s375n2jr1pix644wi6hb5wh5mx3f7"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags (list "-DCMAKE_BUILD_TYPE=Release"
@@ -565,7 +565,7 @@ It can utilize SIMD instructions that are available on modern processors.")
(define-public glpk
(package
(name "glpk")
- (version "4.65")
+ (version "5.0")
(source
(origin
(method url-fetch)
@@ -573,12 +573,13 @@ It can utilize SIMD instructions that are available on modern processors.")
version ".tar.gz"))
(sha256
(base32
- "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))
+ "05bgxidxj8d9xdp82niy7cy36w181cxq7p8vc3y2ixshpgp1642a"))))
(build-system gnu-build-system)
(inputs
`(("gmp" ,gmp)))
(arguments
- `(#:configure-flags '("--with-gmp")))
+ `(#:configure-flags '("--with-gmp"
+ "--disable-static")))
(home-page "https://www.gnu.org/software/glpk/")
(synopsis "GNU Linear Programming Kit, supporting the MathProg language")
(description
@@ -589,6 +590,20 @@ translator for the language. In addition to the C library, a stand-alone
LP/MIP solver is included in the package.")
(license license:gpl3+)))
+(define-public glpk-4
+ (package
+ (inherit glpk)
+ (name "glpk")
+ (version "4.65")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/glpk/glpk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))))
+
(define-public 4ti2
(package
(name "4ti2")
@@ -1894,7 +1909,7 @@ can solve two kinds of problems:
(define-public octave-cli
(package
(name "octave-cli")
- (version "5.2.0")
+ (version "6.1.0")
(source
(origin
(method url-fetch)
@@ -1902,7 +1917,7 @@ can solve two kinds of problems:
version ".tar.lz"))
(sha256
(base32
- "1848dq6nxzal8gwjrcp6xhi5gq96w89nss9d9rz75q408gb3mbl6"))))
+ "0355s0pi8603ccs2j08zym3nalgalslxn83s37zq8nkrrkwxrjfk"))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -2214,13 +2229,13 @@ ASCII text files using Gmsh's own scripting language.")
(define-public veusz
(package
(name "veusz")
- (version "3.2.1")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "veusz" version))
(sha256
- (base32 "00vmfpvyd6f33l5awlf02qdik3gmbhzyfizfwwbx7qnam2i9bbwy"))))
+ (base32 "1q7hi1qwwg4pgiz62isvv1pia85m13bspdpp1q3mrnwl11in0ag0"))))
(build-system python-build-system)
(arguments
`(;; Tests will fail because they depend on optional packages like
@@ -2687,7 +2702,7 @@ bindings to almost all functions of SLEPc.")
(define-public metamath
(package
(name "metamath")
- (version "0.192")
+ (version "0.193")
(source
(origin
(method git-fetch)
@@ -2696,7 +2711,7 @@ bindings to almost all functions of SLEPc.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1k31zw36h2b0w5r6sbn9qc0v4hj42vw53qlhf5l7q2h3p5qlzvic"))))
+ (base32 "1s9hyknfvhj86g3giayyf3dxzg23iij0rs7bdvj075v9qbyhqn9b"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2978,18 +2993,21 @@ also provides threshold-based ILU factorization preconditioners.")
(define-public superlu-dist
(package
(name "superlu-dist")
- (version "6.2.0")
+ (version "6.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://portal.nersc.gov/project/sparse/superlu/"
- "superlu_dist_" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xiaoyeli/superlu_dist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1ynmwqajc9sc3my2hssa5k9s58ggvizqv9rdss0j7w99pbh5mnvw"))
+ (base32 "0fa29yr72p4yq5ln4rgfsawmi5935n4qcr5niz6864bjladz4lql"))
(modules '((guix build utils)))
(snippet
;; Replace the non-free implementation of MC64 with a stub
'(begin
+ (make-file-writable "SRC/mc64ad_dist.c")
(call-with-output-file "SRC/mc64ad_dist.c"
(lambda (port)
(display "
@@ -3067,14 +3085,14 @@ implemented in ANSI C, and MPI for communications.")
(define-public scotch
(package
(name "scotch")
- (version "6.0.6")
+ (version "6.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://gforge.inria.fr/frs/download.php/"
"latestfile/298/scotch_" version ".tar.gz"))
(sha256
- (base32 "1ky4k9r6jvajhqaqnnx6h8fkmds2yxgp70dpr1qzwcyhi2nhqvv8"))
+ (base32 "1184fcv4wa2df8szb5lan6pjh0raarr45pk8ilpvbz23naikzg53"))
(patches (search-patches "scotch-build-parallelism.patch"
"scotch-integer-declarations.patch"))))
(build-system gnu-build-system)
@@ -3122,7 +3140,7 @@ YACC = bison -pscotchyy -y -b y
"COMMON_PTHREAD"
"COMMON_RANDOM_FIXED_SEED"
"INTSIZE64" ;use 'int64_t'
- ;; Prevents symbolc clashes with libesmumps
+ ;; Prevents symbol clashes with libesmumps
"SCOTCH_RENAME"
;; XXX: Causes invalid frees in superlu-dist tests
;; "SCOTCH_PTHREAD"
@@ -3914,7 +3932,8 @@ Fresnel integrals, and similar related functions as well.")
" -DCMAKE_C_FLAGS_RELEASE=\"$(CFLAGS) $(CPPFLAGS)\""
" -DCMAKE_CXX_FLAGS_RELEASE=\"$(CXXFLAGS) $(CPPFLAGS)\""
" -DCMAKE_SKIP_RPATH=TRUE"
- " -DCMAKE_BUILD_TYPE=Release")
+ " -DCMAKE_BUILD_TYPE=Release"
+ " -DCMAKE_INSTALL_LIBDIR=lib")
(string-append "INSTALL_LIB="
(assoc-ref %outputs "out") "/lib")
(string-append "INSTALL_INCLUDE="
@@ -4195,7 +4214,7 @@ revised simplex and the branch-and-bound methods.")
(define-public dealii
(package
(name "dealii")
- (version "9.1.1")
+ (version "9.2.0")
(source
(origin
(method url-fetch)
@@ -4203,7 +4222,7 @@ revised simplex and the branch-and-bound methods.")
"download/v" version "/dealii-" version ".tar.gz"))
(sha256
(base32
- "0xhjv0gzswpjbc43xbrpwfc5848g508l01855nszx3g5gwzlhnzw"))
+ "0fm4xzrnb7dfn4415j24d8v3jkh0lssi86250x2f5wgi83xq4nnh"))
(modules '((guix build utils)))
(snippet
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
@@ -4538,7 +4557,7 @@ structured and unstructured grid problems.")))
(define-public matio
(package
(name "matio")
- (version "1.5.6")
+ (version "1.5.19")
(source
(origin
(method url-fetch)
@@ -4546,7 +4565,7 @@ structured and unstructured grid problems.")))
"matio-" version ".tar.gz"))
(sha256
(base32
- "0y2qymgxank8wdiwc68ap8bxdzrhvyw86i29yh3xgn4z1njfd9ir"))))
+ "0vr8c1mz1k6mz0sgh6n3scl5c3a71iqmy5fnydrgq504icj4vym4"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
@@ -4982,6 +5001,58 @@ be fed to @command{tcalc} through the command line.")
(home-page "https://sites.google.com/site/mohammedisam2000/tcalc")
(license license:gpl3+)))
+(define-public tiny-bignum
+ (let ((commit "1d7a1f9b8e77316187a6b3eae8e68d60a6f9a4d4"))
+ (package
+ (name "tiny-bignum")
+ (version (git-version "0" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kokke/tiny-bignum-c")
+ (commit commit)))
+ (file-name (git-file-name "tiny-bignum" commit))
+ (sha256
+ (base32 "0vj71qlhlaa7d92bfar1kwqv6582dqrby8x3kdw0yzh82k2023g6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "scripts/test_rand.py"
+ (("\t") " ")
+ (("\" % (\\w+)" _ symbol) (string-append "\" % int(" symbol ")")))
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test"))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out") "/share"))
+ (doc (string-append (assoc-ref outputs "out") "/doc")))
+ (mkdir-p share)
+ (install-file "bn.c" share)
+ (install-file "bn.h" share)
+ (mkdir-p doc)
+ (install-file "LICENSE" doc)
+ (install-file "README.md" doc))
+ #t)))))
+ (native-inputs
+ `(("python" ,python-wrapper)))
+ (home-page "https://github.com/kokke/tiny-bignum-c")
+ (synopsis "Small portable multiple-precision unsigned integer arithmetic in C")
+ (description
+ "This library provides portable Arbitrary-precision unsigned integer
+arithmetic in C, for calculating with large numbers. Basic arithmetic (+, -,
+*, /, %) and bitwise operations (&, |, ^. <<, >>) plus increments, decrements
+and comparisons are supported.")
+ (license license:unlicense))))
+
(define-public sundials
(package
(name "sundials")