summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 991933ad14..99ea1c1c48 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -389,6 +389,7 @@ ASCII text files using Gmsh's own scripting language.")
(inputs
`(("gfortran" ,gfortran-4.8)
("lapack" ,lapack)
+ ("superlu" ,superlu)
;; leaving out hdf5 and fftw, as petsc expects them to be built with mpi
;; leaving out opengl, as configuration seems to only be for mac
))
@@ -397,7 +398,12 @@ ASCII text files using Gmsh's own scripting language.")
#:parallel-build? #f
#:configure-flags
`("--with-mpi=0"
- "--with-openmp=1")
+ "--with-openmp=1"
+ "--with-superlu=1"
+ ,(string-append "--with-superlu-include="
+ (assoc-ref %build-inputs "superlu") "/include")
+ ,(string-append "--with-superlu-lib="
+ (assoc-ref %build-inputs "superlu") "/lib/libsuperlu.a"))
#:phases
(alist-replace
'configure