summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ad7d0e22ee..0e6fda3758 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2198,11 +2198,10 @@ specifications.")
(delete 'configure)
(replace 'build
(lambda _
- (with-directory-excursion "lpsolve55"
- (system* "bash" "ccc"))
- (with-directory-excursion "lp_solve"
- (system* "bash" "ccc"))
- #t))
+ (and (with-directory-excursion "lpsolve55"
+ (zero? (system* "bash" "ccc")))
+ (with-directory-excursion "lp_solve"
+ (zero? (system* "bash" "ccc"))))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))