summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c2c7a57d75..5b31596041 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -613,14 +613,14 @@ singular value problems.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.2.6")
+ (version "5.2.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
version "/gnuplot-"
version ".tar.gz"))
(sha256
- (base32 "1vllgap08nhvdmc03idmkdnk9cfl2bp81hps50q1pqrr640qzp9m"))))
+ (base32 "1vglp4la40f5dpj0zdj63zprrkyjgzy068p35bz5dqxjyczm1zlp"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)
("cairo" ,cairo)
@@ -3369,13 +3369,15 @@ packages.")
;; Use `sh', not `/bin/sh'.
(substitute* (find-files "." "Makefile|configure|SpewMakeInc\\.c")
(("/bin/sh")
- "sh"))))
+ "sh"))
+ #t))
;; Fix /bin/sh in generated make files.
(add-after 'configure 'fix-/bin/sh-in-generated-files
(lambda _
(substitute* (find-files "." "^[Mm]ake\\.inc.*")
(("/bin/sh")
- "sh"))))
+ "sh"))
+ #t))
;; ATLAS configure program does not accepts the default flags
;; passed by the 'gnu-build-system'.
(replace 'configure