summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7b900225b5..a2bb2a450e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -23,7 +23,6 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages algebra)
#:use-module (gnu packages compression)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'gnu:))
@@ -67,6 +66,32 @@ the standard data file.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/units/")))
+(define-public gsl
+ (package
+ (name "gsl")
+ (version "1.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gsl/gsl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18qf6jzz1r3mzb5qynywv4xx3z9g61hgkbpkdrhbgqh2g7jhgfc5"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/gsl/")
+ (synopsis "Numerical library for C and C++")
+ (description
+ "The GNU Scientific Library (GSL) is a numerical library for C
+and C++ programmers. It is free software under the GNU General
+Public License.
+
+The library provides a wide range of mathematical routines such
+as random number generators, special functions and least-squares
+fitting. There are over 1000 functions in total with an
+extensive test suite.")
+ (license license:gpl3+)))
+
(define-public pspp
(package
(name "pspp")