summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3bd382f1f3..3b41d1bfd7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2421,7 +2421,7 @@ September 2004}")
`(("python" ,python-2)))
(inputs
`(("gfortran" ,gfortran)
- ("lapack" ,lapack)
+ ("openblas" ,openblas)
("superlu" ,superlu)
;; leaving out hdf5 and fftw, as petsc expects them to be built with mpi
;; leaving out opengl, as configuration seems to only be for mac
@@ -2432,6 +2432,7 @@ September 2004}")
#:configure-flags
`("--with-mpi=0"
"--with-openmp=1"
+ "--with-openblas=1"
"--with-superlu=1")
#:make-flags
;; Honor (parallel-job-count) for build. Do not use --with-make-np,
@@ -6314,14 +6315,14 @@ numeric differences and differences in numeric formats.")
(define-public why3
(package
(name "why3")
- (version "1.3.1")
+ (version "1.3.3")
(source (origin
(method url-fetch)
(uri (string-append "https://gforge.inria.fr/frs/download.php/file"
- "/38291/why3-" version ".tar.gz"))
+ "/38367/why3-" version ".tar.gz"))
(sha256
(base32
- "16zcrc60zz2j3gd3ww93z2z9x2jkxb3kr57y8i5rcgmacy7mw3bv"))))
+ "1n0a2nn1gnk0zg339lh698g4wpk7m8m1vyi2yvifd5adqvk4milw"))))
(build-system ocaml-build-system)
(native-inputs
`(("coq" ,coq)
@@ -6345,8 +6346,8 @@ numeric differences and differences in numeric formats.")
(setenv "CONFIG_SHELL" (which "sh"))
(substitute* "configure"
;; find ocaml-num in the correct directory
- (("\\$DIR/nums.cma") "$DIR/../nums.cma")
- (("\\$DIR/num.cmi") "$DIR/../num.cmi"))
+ (("\\$DIR/nums.cma") "$DIR/num.cma")
+ (("\\$DIR/num.cmi") "$DIR/core/num.cmi"))
#t))
(add-after 'configure 'fix-makefile
(lambda _