summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 9f18afabde..ae795ecba6 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -3,10 +3,11 @@
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
(define-module (gnu packages man)
#:use-module (guix licenses)
+ #:use-module (guix git-download)
#:use-module (guix download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
@@ -136,10 +138,10 @@ a flexible and convenient way.")
(srfi srfi-1))))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("flex" ,flex)
("groff" ,groff))) ;needed at build time (troff, grops, soelim, etc.)
(inputs
- `(("flex" ,flex)
- ("gdbm" ,gdbm)
+ `(("gdbm" ,gdbm)
("groff-minimal" ,groff-minimal)
("less" ,less)
("libpipeline" ,libpipeline)
@@ -162,7 +164,7 @@ the traditional flat-text whatis databases.")
(define-public man-pages
(package
(name "man-pages")
- (version "5.05")
+ (version "5.06")
(source
(origin
(method url-fetch)
@@ -172,7 +174,7 @@ the traditional flat-text whatis databases.")
(string-append "mirror://kernel.org/linux/docs/man-pages/Archive/"
"man-pages-" version ".tar.xz")))
(sha256
- (base32 "0izb6shcczvg37cyd3kzxsfsrffqj1qw9nqhhq9mi4kd36qkbcfm"))))
+ (base32 "0l7ypgl36jswa077qvdh1rcsvnwr64vja6cc32bab86sm41akf3h"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases (delete 'configure))
@@ -239,7 +241,7 @@ automatically.")
(define-public scdoc
(package
(name "scdoc")
- (version "1.9.4")
+ (version "1.10.1")
(source
(origin
(method url-fetch)
@@ -248,7 +250,7 @@ automatically.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "00zc3rzj97gscby31djlqyczvqpyhrl66i44czwzmmn7rc5j03m1"))))
+ "13x7g1r56bshvfmlvapvz35ywnbgsh337kywb5kcv8nc6b3j3q40"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -269,13 +271,14 @@ in C99.")
(version "1.6.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mvertes/txt2man/archive/txt2man-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvertes/txt2man")
+ (commit (string-append "txt2man-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "168cj96974n2z0igin6j1ic1m45zyic7nm5ark7frq8j78rrx4zn"))))
+ "1razjpvlcp85hqli77mwr9nmn5jnv3lm1fxbbqjpx1brv3h1lvm5"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target