summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 5dc7387e92..8c148f7086 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -451,15 +451,15 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A statically-linked Guile that is relocatable--i.e., it can search
;; .scm and .go files relative to its installation directory, rather
;; than in hard-coded configure-time paths.
- (let* ((patches* (cons* (search-patch "guile-relocatable.patch")
- (search-patch "guile-default-utf8.patch")
- (search-patch "guile-linux-syscalls.patch")
- (origin-patches (package-source guile-2.0))))
- (source* (origin (inherit (package-source guile-2.0))
- (patches patches*)))
+ (let* ((patches (cons* (search-patch "guile-relocatable.patch")
+ (search-patch "guile-default-utf8.patch")
+ (search-patch "guile-linux-syscalls.patch")
+ (origin-patches (package-source guile-2.0))))
+ (source (origin (inherit (package-source guile-2.0))
+ (patches patches)))
(guile (package (inherit guile-2.0)
(name (string-append (package-name guile-2.0) "-static"))
- (source source*)
+ (source source)
(synopsis "Statically-linked and relocatable Guile")
(propagated-inputs
`(("bdw-gc" ,libgc)