summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9dcaea364c..15aeb9355b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -329,7 +329,7 @@ and corrections. It is based on a Bayesian filter.")
(define-public offlineimap
(package
(name "offlineimap")
- (version "7.0.9")
+ (version "7.0.10")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/OfflineIMAP/offlineimap/"
@@ -337,7 +337,7 @@ and corrections. It is based on a Bayesian filter.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "04kapx0ddz7ccwhcjshkml2y916wcan3rl28mpmq25p4gywlkhxf"))))
+ "0h8mgmwkvwh8x3yam32ipqkzcz4g1dmkbni3v1755lkm0z132m3j"))))
(build-system python-build-system)
(native-inputs
`(("asciidoc" ,asciidoc)
@@ -537,14 +537,14 @@ invoking @command{notifymuch} from the post-new hook.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.23.2")
+ (version "0.23.3")
(source (origin
(method url-fetch)
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
version ".tar.gz"))
(sha256
(base32
- "1g4p5hsrqqbqk6s2w756als60wppvjgpyq104smy3w9vshl7bzgd"))))
+ "10hqjnl5aavf9clfmx3y832jyz58fplmc3f58pip9dq30b7sap8g"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "V=1") ; Verbose test output.
@@ -568,11 +568,6 @@ invoking @command{notifymuch} from the post-new hook.")
;; Patch various inline shell invocations.
(substitute* (find-files "test" "\\.sh$")
(("/bin/sh") (which "sh")))
- ;; XXX: Some signature verification tests fail with
- ;; gnupg-2.1.16, so we skip them. See this thread:
- ;; https://notmuchmail.org/pipermail/notmuch/2016/023688.html
- (setenv "NOTMUCH_SKIP_TESTS"
- "T350-crypto.2 T350-crypto.3 T350-crypto.4 T350-crypto.15")
#t)))))
(native-inputs
`(("bash-completion" ,bash-completion)
@@ -938,7 +933,7 @@ facilities for checking incoming mail.")
(define-public dovecot
(package
(name "dovecot")
- (version "2.2.25")
+ (version "2.2.26.0")
(source
(origin
(method url-fetch)
@@ -946,7 +941,7 @@ facilities for checking incoming mail.")
(version-major+minor version) "/"
name "-" version ".tar.gz"))
(sha256 (base32
- "0rwn5wc5b8j9fzqcjggdgpzmb77myrf4ra294z1gg5v3hhng7nfq"))))
+ "01bgj8b2whi35ghbxb19nmr3xvx2zgjzxxw1crgx2v73kprs34pn"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -968,6 +963,15 @@ facilities for checking incoming mail.")
"doc/example-config/Makefile.in")
(("pkgsysconfdir = .*")
"pkgsysconfdir = /tmp/etc"))
+ #t))
+ (add-after
+ 'unpack 'patch-other-shebangs
+ (lambda _
+ (substitute*
+ "src/lib-program-client/test-program-client-local.c"
+ (("/bin/echo") (which "echo"))
+ (("/bin/cat") (which "cat"))
+ (("/bin/false") (which "false")))
#t)))))
(home-page "http://www.dovecot.org")
(synopsis "Secure POP3/IMAP server")
@@ -1372,8 +1376,6 @@ maintained.")
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/khard")))
(copy-recursively "misc/khard" doc)))))))
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(propagated-inputs
`(("python2-vobject" ,python2-vobject)
("python2-pyyaml" ,python2-pyyaml)
@@ -1744,7 +1746,7 @@ for OpenSMTPD to extend its functionality.")
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; Requires mailman running
- (inputs
+ (propagated-inputs
`(("python-six" ,python-six)
("python-httplib2" ,python-httplib2)))
(home-page "https://launchpad.net/mailman.client")
@@ -1752,12 +1754,7 @@ for OpenSMTPD to extend its functionality.")
(description
"The mailmanclient library provides official Python bindings for
the GNU Mailman 3 REST API.")
- (properties `((python2-variant . ,(delay python2-mailmanclient))))
(license lgpl3+)))
(define-public python2-mailmanclient
- (let ((base (package-with-python2
- (strip-python2-variant python-mailmanclient))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools))))))
+ (package-with-python2 python-mailmanclient))