summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm143
1 files changed, 128 insertions, 15 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c538d77aaf..35584c497a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
@@ -27,21 +27,22 @@
;;; Copyright © 2018, 2019, 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2020, 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
-;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2020, 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,6 +90,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages groff)
@@ -156,7 +158,9 @@
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system go)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system guile)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -164,6 +168,51 @@
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
+(define-public abook
+ (package
+ (name "abook")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://abook.sourceforge.io/devel/abook-" version ".tar.gz"))
+ (sha256
+ (base32 "1yf0ifyjhq2r003pnpn92mn0924bn9yxjifxxj2ldcsgd7w0vagh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Fix "undefined reference to `field_id'" errors.
+ (add-after 'unpack 'fix-build-with-recent-gcc
+ (lambda _
+ (substitute* '("database.c" "database.h")
+ (("^inline int" all) (string-append "extern " all)))))
+ ;; Fix following error during bootstrap: "gettext infrastructure
+ ;; mismatch: using a Makefile.in.in from gettext version 0.18 but the
+ ;; autoconf macros are from gettext version 0.20".
+ (add-before 'bootstrap 'fix-gettext-macro-version
+ (lambda _
+ (substitute* "po/Makefile.in.in"
+ (("0.18") "0.20"))))
+ (replace 'bootstrap
+ (lambda _
+ (invoke "aclocal")
+ (invoke "automake" "--add-missing")
+ (invoke "autoconf"))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (home-page "https://abook.sourceforge.io/")
+ (synopsis "Text-based addressbook")
+ (description
+ "Abook is a text-based addressbook program designed to use with Mutt mail
+client.")
+ (license license:gpl2)))
+
(define-public anubis
(package
(name "anubis")
@@ -318,6 +367,37 @@ software.")
;; Libraries are under LGPLv3+, and programs under GPLv3+.
(list license:gpl3+ license:lgpl3+))))
+(define-public go-gitlab.com-shackra-goimapnotify
+ (let ((commit "832bc7112db9b28e28d69e90b91ea6c005244c9b")
+ (revision "0"))
+ (package
+ (name "go-gitlab.com-shackra-goimapnotify")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/shackra/goimapnotify")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h27kshx4vwl5k6vc2szsq3d701fzs4gczjypz907f8hj0lrnjmy"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gitlab.com/shackra/goimapnotify"))
+ (propagated-inputs
+ `(("go-github-com-emersion-go-imap" ,go-github-com-emersion-go-imap)
+ ("go-github-com-emersion-go-imap-idle" ,go-github-com-emersion-go-imap-idle)
+ ("go-github-com-emersion-go-sasl" ,go-github-com-emersion-go-sasl)
+ ("go-github-com-sirupsen-logrus" ,go-github-com-sirupsen-logrus)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (synopsis "Execute scripts on IMAP mailbox changes.")
+ (description
+ "Script to execute scripts on IMAP mailbox changes (new/deleted/updated
+messages) using IDLE. Implemented in Go.")
+ (home-page "https://gitlab.com/shackra/goimapnotify")
+ (license license:gpl3+))))
+
(define-public guile2.2-mailutils
(package
(inherit mailutils)
@@ -413,7 +493,7 @@ to run without any changes.")
(define-public fetchmail
(package
(name "fetchmail")
- (version "6.4.17")
+ (version "6.4.18")
(source
(origin
(method url-fetch)
@@ -421,7 +501,7 @@ to run without any changes.")
(version-major+minor version) "/"
"fetchmail-" version ".tar.xz"))
(sha256
- (base32 "1ijh9l7pg2yk5s5h1yj3vpd1az31giqy9bjrna10daj13gqws6x4"))))
+ (base32 "17r5zfk9yh7jhgdb360dlzx5fx9lsbmalasx6zgxw9v9vjycjb9h"))))
(build-system gnu-build-system)
(inputs
`(("openssl" ,openssl)))
@@ -495,7 +575,7 @@ operating systems.")
(define-public neomutt
(package
(name "neomutt")
- (version "20201127")
+ (version "20210205")
(source
(origin
(method git-fetch)
@@ -504,7 +584,7 @@ operating systems.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1yhpz591jhcjpwllgppwf7vl7z2rnaqfphsvqd1sihd9k4lwch06"))))
+ (base32 "15kr9nvb4j8lx5rl2yapv231rbp4sbn709vv82pfhx5717x3yf00"))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
@@ -2685,14 +2765,14 @@ easily (one at a time).")
(define-public mpop
(package
(name "mpop")
- (version "1.4.12")
+ (version "1.4.13")
(source
(origin
(method url-fetch)
(uri (string-append "https://marlam.de/mpop/releases/"
"mpop-" version ".tar.xz"))
(sha256
- (base32 "02j8qfd44dfyq1sq7r9znj9y6wam39ncch1sc8chcdlw5nsmaqsz"))))
+ (base32 "1hbx69d6ivbvjajrcp54fdb3g1ms4ydj0ybf3bfhlravqrk88jdk"))))
(build-system gnu-build-system)
(inputs
`(("gnutls" ,gnutls)))
@@ -3136,6 +3216,39 @@ writing OpenSMTPd filters.")
messages with @acronym{DKIM, DomainKeys Identified Mail} (RFC 4871).")
(license license:expat)))
+(define-public opensmtpd-filter-rspamd
+ (package
+ (name "opensmtpd-filter-rspamd")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/poolpOrg/filter-rspamd")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1qhrw20q9y44ffgx5k14nvqc9dh47ihywgzza84g0zv9xgif7hd5"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/poolpOrg/filter-rspamd"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-bootstrap-variables
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Tell the build system where to install binaries
+ (let* ((out (assoc-ref outputs "out"))
+ (libexec (string-append out "/libexec/opensmtpd")))
+ (setenv "GOBIN" libexec)))))))
+ (native-inputs
+ `(("opensmtpd" ,opensmtpd)))
+ (home-page "https://github.com/poolpOrg/filter-rspamd")
+ (synopsis "OpenSMTPd filter to request an Rspamd analysis")
+ (description
+ "The @command{filter-rspamd} OpenSMTPd filter implements the
+Rspamd protocol and allows OpenSMTPd to request an Rspamd analysis of
+an SMTP transaction before a message is committed to queue.")
+ (license license:isc)))
+
(define-public mailman
(package
(name "mailman")
@@ -3791,13 +3904,13 @@ servers. The 4rev1 and 4 versions of IMAP are supported.")
(define-public urlscan
(package
(name "urlscan")
- (version "0.9.5")
+ (version "0.9.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "urlscan" version))
(sha256
- (base32 "07vcwirap0p4dkqrqblfn1q017slgd8m6qyijvbi3gxnr09pbyx2"))))
+ (base32 "09lxi7dhn49fpb3ij4cgrhj3qqqqs9rcxbjb7p9smw5wblrqpzga"))))
(build-system python-build-system)
(propagated-inputs
`(("python-urwid" ,python-urwid)))
@@ -3839,8 +3952,8 @@ It is a replacement for the @command{urlview} program.")
(license license:gpl2+)))
(define-public mumi
- (let ((commit "8c82c8f104ff0013e2bfb3d6b4277280f32446a6")
- (revision "3"))
+ (let ((commit "9f070bd90adc67064cd8aff4e40f303d5957ef4a")
+ (revision "5"))
(package
(name "mumi")
(version (git-version "0.0.1" revision commit))
@@ -3852,7 +3965,7 @@ It is a replacement for the @command{urlview} program.")
(file-name (git-file-name name version))
(sha256
(base32
- "1gkwagy7qplzq2x2zqsbrwhlilxviqb0dqhrvnnhxd7z8wvyzcsi"))))
+ "1ym1j3nzy8qhd1ydadccbgm0nckkmnq3vnz9qh9x8rasx7zg1ldp"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)