summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 709c64d25b..23a8710b9b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -604,7 +604,7 @@ operating systems.")
(define-public neomutt
(package
(name "neomutt")
- (version "20210205")
+ (version "20211015")
(source
(origin
(method git-fetch)
@@ -613,7 +613,7 @@ operating systems.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "15kr9nvb4j8lx5rl2yapv231rbp4sbn709vv82pfhx5717x3yf00"))))
+ (base32 "06rjx81ahrwcl1zhpdgqngr99l0cx1i4fwaaxd6rsn9zsj3ixdir"))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
@@ -3704,7 +3704,7 @@ operators and scripters.")
(define-public alpine
(package
(name "alpine")
- (version "2.24.2")
+ (version "2.25")
(source
(origin
(method git-fetch)
@@ -3717,13 +3717,14 @@ operators and scripters.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ibwss04j4qbhpd3jcw3d4xjf8jnmb9fi3sz58a99xw3awkfjabd"))
+ (base32 "0z6dp3cpz1dmbxw41ravsx1bxychafp0ij8gvj96mzz7rm9pdnq3"))
(modules '((guix build utils)))
(snippet
'(begin
;; Remove pre-built binaries scattered across the source repository.
- (for-each delete-file (find-files "." "\\.(dll|exe)"))
- #t))))
+ (for-each delete-file (find-files "." "\\.(dll|exe)"))))
+ (patches
+ (search-patches "alpine-fix-privacy-policy-crash.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -3749,14 +3750,12 @@ operators and scripters.")
;; ‘/etc/shadow exists in the build environment’. It does not.
(lambda _
(substitute* "configure"
- (("test -f /etc/shadow") "true"))
- #t))
+ (("test -f /etc/shadow") "true"))))
(add-after 'unpack 'make-reproducible
(lambda _
;; This removes time-dependent code to make alpine reproducible.
(substitute* "pico/blddate.c"
- (("%02d-%s-%d") "1970-01-01"))
- #t)))))
+ (("%02d-%s-%d") "1970-01-01")))))))
(inputs
`(("ncurses" ,ncurses)
("openssl" ,openssl)