summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm48
1 files changed, 46 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3d7b0e4632..2a6a17c804 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -300,7 +300,7 @@ operating systems.")
(define-public neomutt
(package
(name "neomutt")
- (version "20180323")
+ (version "20180716")
(source
(origin
(method url-fetch)
@@ -308,7 +308,7 @@ operating systems.")
"/archive/" name "-" version ".tar.gz"))
(sha256
(base32
- "12v7zkm809cvjxfz0n7jb4qa410ns1ydyf0gjin99vbdrlj88jac"))))
+ "0072in2d6znwqq461shsaxlf40r4zr7w3j9848qvm4xlh1lq52dx"))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
@@ -2554,3 +2554,47 @@ and binaries. It supports offline reading, scoring and killfiles, yEnc, NZB,
PGP handling, multiple servers, and secure connections.")
;; License of the docs: fdl-1.1; Others: gpl2.
(license (list fdl1.1+ gpl2))))
+
+(define-public imapfilter
+ (package
+ (name "imapfilter")
+ (version "2.6.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/lefcha/imapfilter/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yslvwr3w5fnl06gfrp0lim8zdlasx3cvgd2fsqi0695xnb9bsms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-include-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pcre (assoc-ref inputs "pcre")))
+ (substitute* "src/Makefile"
+ (("INCDIRS =")
+ (string-append "INCDIRS ="
+ "-I" pcre "/include")))
+ #t))))))
+ (native-inputs
+ `(("lua" ,lua)
+ ("pcre" ,pcre)
+ ("openssl" ,openssl)))
+ (home-page "https://github.com/lefcha/imapfilter")
+ (synopsis "IMAP mail filtering utility")
+ (description "IMAPFilter is a mail filtering utility. It connects
+to remote mail servers using IMAP, sends searching queries to the server and
+processes mailboxes based on the results. It can be used to delete, copy,
+move, flag, etc. messages residing in mailboxes at the same or different mail
+servers. The 4rev1 and 4 versions of IMAP are supported.")
+ (license license:expat)))