summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm65
1 files changed, 42 insertions, 23 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 73a17fb21b..35b7d27df3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
-;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
@@ -126,24 +126,14 @@
(define-public mailutils
(package
(name "mailutils")
- (version "3.4")
+ (version "3.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mailutils/mailutils-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "1dn71p85wlyisnwsb485sk3q5v393k3dizsa9fmimskdwjwgk3ch"))
- (patches
- (search-patches "mailutils-uninitialized-memory.patch"))
- (snippet
- ;; For a rebuild of the Flex/Bison byproducts touched by the
- ;; patch above.
- '(begin
- (for-each delete-file
- '("mh/mh_alias_lex.c"
- "libmailutils/cfg/parser.c"))
- #t))))
+ "1wx275w38fwni2abc8g7g3irbk332vr34byxd72zqfdiznsqgims"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -194,19 +184,22 @@
#t)))
;; TODO: Add `--with-sql'.
- #:configure-flags '("--sysconfdir=/etc")
+ #:configure-flags (list "--sysconfdir=/etc"
+
+ ;; Add "/2.2" to the installation directory.
+ (string-append "--with-guile-site-dir="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2"))
+
#:parallel-tests? #f))
(native-inputs
- ;; Note: Bison and Flex needed due to
- ;; 'mailutils-uninitialized-memory.patch'.
- `(("bison" ,bison)
- ("flex" ,flex)
- ("perl" ,perl))) ;for 'gylwrap'
+ `(("perl" ,perl))) ;for 'gylwrap'
(inputs
`(("dejagnu" ,dejagnu)
("m4" ,m4)
("texinfo" ,texinfo)
- ("guile" ,guile-2.0)
+ ("guile" ,guile-2.2)
+ ("gsasl" ,gsasl)
("gnutls" ,gnutls)
("ncurses" ,ncurses)
("readline" ,readline)
@@ -1857,7 +1850,7 @@ converts them to maildir format directories.")
(define-public mpop
(package
(name "mpop")
- (version "1.2.8")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
@@ -1865,7 +1858,7 @@ converts them to maildir format directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1skrda7lbks5h0v03ab8bhpg6ma1b63if8x9x3kb2fv70x2pkhqn"))))
+ "14xsvpm5bc1wycisq882gqrnamnyi1q4rlk6anlw8ihzvwgm4h2j"))))
(build-system gnu-build-system)
(inputs
`(("gnutls" ,gnutls)
@@ -2621,3 +2614,29 @@ within the message, and allows you to choose one or more URLs to send to your
Web browser. Alternatively, it send a list of all URLs to stdout. It is a
replacement for the @code{urlview} program.")
(license gpl2)))
+
+(define-public tnef
+ (package
+ (name "tnef")
+ (version "1.4.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/verdammelt/tnef.git")
+ (commit version)))
+ (sha256
+ (base32
+ "0cq2xh5wd74qn6k2nnw5rayxgqhjl3jbzf4zlc4babcwxrv32ldh"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (arguments `(#:parallel-tests? #f)) ;tests are side-effect'y
+ (home-page "https://github.com/verdammelt/tnef")
+ (synopsis "Unpack @code{application/ms-tnef} attachments")
+ (description
+ "TNEF is a tar-like program that unpacks MIME attachments of type
+@code{application/ms-tnef}.")
+ (license gpl2+)))