summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 0e11da41ca..0c02fbcfc7 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -946,14 +946,14 @@ main intended application of Autograd is gradient-based optimization.")
(name "lightgbm")
(version "2.0.12")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Microsoft/LightGBM/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Microsoft/LightGBM")
+ (commit (string-append "v" version))))
(sha256
(base32
- "132zf0yk0545mg72hyzxm102g3hpb6ixx9hnf8zd2k55gas6cjj1"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "0jlvyn7k81dzrh9ij3zw576wbgiwmmr26rzpdxjn1dbpc3njpvzi"))
+ (file-name (git-file-name name version))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-nose" ,python-nose)))
@@ -968,8 +968,8 @@ main intended application of Autograd is gradient-based optimization.")
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion ,(string-append "../LightGBM-" version)
+ (lambda _
+ (with-directory-excursion "../source"
(invoke "pytest" "tests/c_api_test/test_.py")))))))
(build-system cmake-build-system)
(home-page "https://github.com/Microsoft/LightGBM")
@@ -1817,8 +1817,7 @@ advanced research.")
"1k8szlpm19rcwcxdny9qdm3gmaqq8akb4xlvrzyz8c2d679aak6l"))))
(build-system python-build-system)
(propagated-inputs
- `(("ipython" ,(prompt-toolkit-2-instead-of-prompt-toolkit
- python-ipython))
+ `(("ipython" ,python-ipython)
("numpy" ,python-numpy)
("pandas" ,python-pandas)
("scipy" ,python-scipy)))