summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 084e62cca4..b56468f8c1 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages xml)
@@ -873,3 +874,37 @@ the following advantages:
such as online, hashing, allreduce, reductions, learning2search, active, and
interactive learning.")
(license license:bsd-3)))
+
+(define-public python2-fastlmm
+ (package
+ (name "python2-fastlmm")
+ (version "0.2.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastlmm" version ".zip"))
+ (sha256
+ (base32
+ "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2)) ; only Python 2.7 is supported
+ (propagated-inputs
+ `(("python2-numpy" ,python2-numpy)
+ ("python2-scipy" ,python2-scipy)
+ ("python2-matplotlib" ,python2-matplotlib)
+ ("python2-pandas" ,python2-pandas)
+ ("python2-scikit-learn" ,python2-scikit-learn)
+ ("python2-pysnptools" ,python2-pysnptools)))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python2-cython" ,python2-cython)
+ ("python2-mock" ,python2-mock)
+ ("python2-nose" ,python2-nose)))
+ (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
+ (synopsis "Perform genome-wide association studies on large data sets")
+ (description
+ "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
+Models, is a program for performing both single-SNP and SNP-set genome-wide
+association studies (GWAS) on extremely large data sets.")
+ (license license:asl2.0)))