summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1cea91977f..75faeb8eb8 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -581,16 +581,16 @@ tools. This enables both rapid prototyping of data pipelines and extensibility
in terms of new algorithms.")
(license license:gpl3+)))
-(define-public python-onnx
+(define-public onnx
(package
- (name "python-onnx")
+ (name "onnx")
(version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "onnx" version))
- (patches (search-patches "python-onnx-use-system-googletest.patch"
- "python-onnx-shared-libraries.patch"))
+ (patches (search-patches "onnx-use-system-googletest.patch"
+ "onnx-shared-libraries.patch"))
(sha256
(base32 "0yjv2axz2vc2ysniwislsp53fsb8f61y1warrr2ppn2d9ijml1d9"))
(modules '((guix build utils)))
@@ -658,6 +658,12 @@ computation graph model, as well as definitions of built-in operators and
standard data types.")
(license license:expat)))
+(define-public python-onnx
+ ;; This used to be called "python-onnx" because it provided nothing but
+ ;; Python bindings. The package now provides shared libraries and C++
+ ;; headers, hence the name change.
+ (deprecated-package "python-onnx" onnx))
+
(define-public rxcpp
(package
(name "rxcpp")