summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm313
1 files changed, 186 insertions, 127 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 9813005a34..d91efe715d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -3,9 +3,9 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -124,7 +124,7 @@ to statistics about the system on which it's run.")
(define-public lxqt-build-tools
(package
(name "lxqt-build-tools")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
@@ -132,7 +132,7 @@ to statistics about the system on which it's run.")
"/download/" version
"/lxqt-build-tools-" version ".tar.xz"))
(sha256
- (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
+ (base32 "0n0p0mf12n9f7zm2592779rpqrbcamfdz87nnjb8j058bc8g3214"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -157,7 +157,7 @@ itself as well as other components maintained by the LXQt project.")
(define-public libqtxdg
(package
(name "libqtxdg")
- (version "3.2.0")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
@@ -165,7 +165,7 @@ itself as well as other components maintained by the LXQt project.")
"https://github.com/lxqt/libqtxdg/releases/download/"
version "/libqtxdg-" version ".tar.xz"))
(sha256
- (base32 "0lq548pa69hfvnbj2ypba5ygm8n6v6g7bqqm8p5g538l1l3394cl"))))
+ (base32 "1mnnq8vbf5xjlrzajzfkay0yzzxri0zz0xi8x8rmxpw38xmglq8h"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -182,6 +182,8 @@ itself as well as other components maintained by the LXQt project.")
;; required by Qt5XdgIconLoader.pc
`(("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)))
(home-page "https://github.com/lxqt/libqtxdg")
(synopsis "Qt implementation of freedesktop.org xdg specifications")
(description "Libqtxdg implements the freedesktop.org xdg specifications
@@ -191,7 +193,7 @@ in Qt.")
(define-public liblxqt
(package
(name "liblxqt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
@@ -199,13 +201,10 @@ in Qt.")
"https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (base32 "1gb922npf6nw4w3nkvh4czk8xmdzzqkzq3zgl1h303fjaib359qs"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -213,6 +212,13 @@ in Qt.")
(substitute* "CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"share/polkit-1/actions"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -233,14 +239,14 @@ components of the LXQt desktop environment.")
(define-public libsysstat
(package
(name "libsysstat")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0ngz8v3bixsdg96d5ipcyxd6nsrg52974xdxy9rnimahlv1yaxn3"))))
+ (base32 "0rz9w49khra9kl91kfnd3wxkldy1fqf6755mvlgbsqxb1yv8597w"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no tests
(inputs
@@ -259,14 +265,14 @@ and memory usage or network traffic.")
(define-public lxqt-about
(package
(name "lxqt-about")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "08imj7p77ifzfxnn8c482mhrvfx9gi0rb43ab5rw1rkmfvax2n5w"))))
+ (base32 "01xp5ddcxc9wvl7jm4179hjrirj07mpzm9z50936d1fqx34wfbis"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -280,9 +286,19 @@ and memory usage or network traffic.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'setenv
+ (lambda _
+ (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
+ #t)))))
(home-page "https://lxqt.org")
(synopsis "Provides information about LXQt and the system")
(description "lxqt-about is a dialogue window providing information about
@@ -292,14 +308,14 @@ LXQt and the system it's running on.")
(define-public lxqt-admin
(package
(name "lxqt-admin")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0qvpv668ja83ydbdrlal1596xhag3xlkbd6qlh9xwdpb7nysvns1"))))
+ (base32 "0f0skkxqyhpidpd5phliax869v4n2whvglg8rahzia2zhw4ylzry"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -313,9 +329,6 @@ LXQt and the system it's running on.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -323,6 +336,14 @@ LXQt and the system it's running on.")
(substitute* "lxqt-admin-user/CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"share/polkit-1/actions"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("lxqt-admin-time/CMakeLists.txt"
+ "lxqt-admin-user/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org")
(synopsis "LXQt system administration tool")
@@ -333,25 +354,28 @@ the operating system LXQt is running on.")
(define-public lxqt-config
(package
(name "lxqt-config")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0rizhl2v41kpgp57a61r6nmwcdw8nh9hprrrf33nfrdw8hpwxb95"))))
+ (base32 "16k36knv6d72gg8hp7423l3ic43y3l3zbaf3spqn2a354y30myrg"))))
(build-system cmake-build-system)
(inputs
- `(("kwindowsystem" ,kwindowsystem)
+ `(("eudev" ,eudev)
+ ("kwindowsystem" ,kwindowsystem)
("libkscreen" ,libkscreen)
("liblxqt" ,liblxqt)
("libqtxdg" ,libqtxdg)
("libxcursor" ,libxcursor)
+ ("libxi" ,libxi)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)
("solid" ,solid)
+ ("xf86-input-libinput" ,xf86-input-libinput)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -359,9 +383,6 @@ the operating system LXQt is running on.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -369,6 +390,20 @@ the operating system LXQt is running on.")
(substitute* '("src/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("lxqt-config-file-associations/CMakeLists.txt"
+ "lxqt-config-brightness/CMakeLists.txt"
+ "lxqt-config-appearance/CMakeLists.txt"
+ "lxqt-config-locale/CMakeLists.txt"
+ "lxqt-config-monitor/CMakeLists.txt"
+ "lxqt-config-input/CMakeLists.txt"
+ "liblxqt-config-cursor/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org")
(synopsis "Tools to configure LXQt and the underlying operating system")
@@ -379,14 +414,14 @@ configuration of both LXQt and the underlying operating system.")
(define-public lxqt-globalkeys
(package
(name "lxqt-globalkeys")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1gyvcjbhi7zpvgz1sf773dv9gc35hx5fz023njp9r4vl0dpcavgd"))))
+ (base32 "0m6svwy20bfy9d21g5l0qzjndph3rd8zqagmqgdjzjhh3lxwrsrk"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -401,9 +436,6 @@ configuration of both LXQt and the underlying operating system.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -412,6 +444,13 @@ configuration of both LXQt and the underlying operating system.")
"xdg/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "config/CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Daemon used to register global keyboard shortcuts")
@@ -423,14 +462,14 @@ as a whole and are not limited to distinct applications.")
(define-public lxqt-notificationd
(package
(name "lxqt-notificationd")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1l0hdbvghyhqgvy4pih7rvz26bc6yc8a3l1bdj11hnkw62h1i7d6"))))
+ (base32 "1kiag3fcx12qmslln6x6lwvm4f1spymwf71389kdya3vwx7hkmcy"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -444,9 +483,6 @@ as a whole and are not limited to distinct applications.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no test target
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -454,6 +490,14 @@ as a whole and are not limited to distinct applications.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("config/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt notification daemon")
@@ -464,14 +508,14 @@ according to the Desktop Notifications Specification.")
(define-public lxqt-openssh-askpass
(package
(name "lxqt-openssh-askpass")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0l2272gya8jgv71bvg2hz37lnhiznv4ng3j0p6j79f99hwb5ygpk"))))
+ (base32 "1fvbgjidpifn420avh8n1gym49vcz6zgayz7xygg1x93s4awy1cs"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -485,9 +529,15 @@ according to the Desktop Notifications Specification.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
+ #t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI to query passwords on behalf of SSH agents")
(description "lxqt-openssh-askpass is a GUI to query credentials on behalf
@@ -497,14 +547,14 @@ of other programs.")
(define-public lxqt-panel
(package
(name "lxqt-panel")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1qraigzq7nc5a2q6f5ybxwx07gxffa3m3bg7fiv6ppwss51xqfd1"))))
+ (base32 "1r3wx0v3jm7j41h7gxr49izc9xa1afvrzq4wcdm0qbj98qa1rgpq"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -534,9 +584,6 @@ of other programs.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -545,6 +592,14 @@ of other programs.")
"menu/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("cmake/BuildPlugin.cmake"
+ "panel/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt desktop panel")
@@ -554,14 +609,14 @@ of other programs.")
(define-public lxqt-policykit
(package
(name "lxqt-policykit")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1d97fys6625nk4q6irp0jhsbk30xi7idnii1f3vrrrdcl2cahagp"))))
+ (base32 "127rqb0nprybkc41lk0yq0r0dk5pbbw22gvrm4pwag71qh8wpk5i"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -579,8 +634,6 @@ of other programs.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no test target
- #:configure-flags
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -588,6 +641,13 @@ of other programs.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt PolicyKit agent")
@@ -598,14 +658,14 @@ LXQt.")
(define-public lxqt-powermanagement
(package
(name "lxqt-powermanagement")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "15nvdypyjwnp7k3d2pkhdbmaqb3ccacmh95rbdbc5mr7yrjy9613"))))
+ (base32 "06bvgbkbl9p9n8ba5cfsynqgmpb5c8yfnsvp7zqhflj8k9p9msip"))))
(build-system cmake-build-system)
(inputs
`(("kidletime" ,kidletime)
@@ -621,9 +681,6 @@ LXQt.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -631,6 +688,14 @@ LXQt.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("config/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Power management module for LXQt")
@@ -642,14 +707,14 @@ when laptop batteries are low on power.")
(define-public lxqt-qtplugin
(package
(name "lxqt-qtplugin")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0nnwbc99njpsyqb0cy3x0srcgwa7qrnq0qwcyx7fbvwsq1l8cz56"))))
+ (base32 "18y7xfxwyismcycg70q6r8zrcygz1pdcvg6lqc6ba7azqb9806ds"))))
(build-system cmake-build-system)
(inputs
`(("libdbusmenu-qt" ,libdbusmenu-qt)
@@ -680,14 +745,14 @@ Qt with LXQt.")
(define-public lxqt-runner
(package
(name "lxqt-runner")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0dsg6fdcqbl7gza0sg1pb49zn5x31q7zx77jp7mkf6wc2lv8lali"))))
+ (base32 "1c687shypivkhjrpzs1jcy5l2i8d7xzm31c4is1xx6x9nbkgm4bm"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -705,9 +770,6 @@ Qt with LXQt.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -715,6 +777,13 @@ Qt with LXQt.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Tool used to launch programs quickly by typing their names")
@@ -725,14 +794,14 @@ allows for launching applications or shutting down the system.")
(define-public lxqt-session
(package
(name "lxqt-session")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1aibppppmg46ybbajx2qc395l0yp9rqlp2am01fqjxadsf8vci5z"))))
+ (base32 "11i2vimv3336dvvxb6y5csdybwjncr7cq3kwlj52vkpisnxslvgy"))))
(build-system cmake-build-system)
(inputs
`(("eudev" ,eudev)
@@ -749,8 +818,6 @@ allows for launching applications or shutting down the system.")
("qttools" ,qttools)))
(arguments
`(#:tests? #f
- #:configure-flags
- `("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -759,6 +826,15 @@ allows for launching applications or shutting down the system.")
"config/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("lxqt-config-session/CMakeLists.txt"
+ "lxqt-leave/CMakeLists.txt"
+ "lxqt-session/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Session manager for LXQt")
@@ -769,14 +845,14 @@ for the LXQt desktop environment.")
(define-public lxqt-sudo
(package
(name "lxqt-sudo")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1j28wlw4rkzvr85yl78fqkvz7sv7dykm9ghm63xdkskfjbsas1cf"))))
+ (base32 "0mbygp2kkppwk7sxvpnwavdwrx88mh7ldcg6xm3zw1ndp29danay"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -792,9 +868,15 @@ for the LXQt desktop environment.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
+ #t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI frontend for sudo/su")
(description "lxqt-sudo is a graphical front-end of commands sudo and su
@@ -805,14 +887,14 @@ permissions of other users including root.")
(define-public lxqt-themes
(package
(name "lxqt-themes")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
+ (base32 "0p7svdpp0z44hvgrp2aip6hym0gdhbanyxsz6iz8sjnn28c995ia"))))
(build-system cmake-build-system)
(native-inputs
`(("lxqt-build-tools" ,lxqt-build-tools)))
@@ -843,20 +925,17 @@ for LXQt.")
(define-public libfm-qt
(package
(name "libfm-qt")
- (version "0.13.1")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0p0lbz7dh5c38zq3yp1v1mm99ymg7mqr3h7yzniif2hipmgvxsv9"))))
+ (base32 "06p3wqpc574v9f94wkq9hqmbbvb9q8phfpq301z55c5r939f4hrp"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO : prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(inputs
`(("glib" ,glib)
("libexif" ,libexif)
@@ -879,14 +958,14 @@ components to build desktop file managers which belongs to LXDE.")
(define-public pcmanfm-qt
(package
(name "pcmanfm-qt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "08jprkkk62pk34q9lxa207bh27xi86fj8jxfd5z3w2m5j5nim5mz"))))
+ (base32 "0x3c25inlxll965xszx37mnl5gp3smm2h7x04f67z0qlh3vsbrjq"))))
(build-system cmake-build-system)
(inputs
`(("libfm-qt" ,libfm-qt)
@@ -898,9 +977,6 @@ components to build desktop file managers which belongs to LXDE.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -921,14 +997,14 @@ LXDE.")
(define-public compton-conf
(package
(name "compton-conf")
- (version "0.4.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0q3yx2a6wf8yahrwgvhmv9sd7gmrhid528vrqy04dg8m5cx1bjci"))))
+ (base32 "11n8k59jd0q2x66cispc9dpk139mp6j99hq1yjccxvh21vhc7mbc"))))
(build-system cmake-build-system)
(inputs
`(("libconfig" ,libconfig)
@@ -939,9 +1015,6 @@ LXDE.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -959,14 +1032,14 @@ manager Compton.")
(define-public lximage-qt
(package
(name "lximage-qt")
- (version "0.7.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1mwjh6lrjayr9snsmabkl5qs4xm6d27mfz8k3jxfm5dk3pjj1b0w"))))
+ (base32 "0iiq55rm4z2jp19q1pbd2whifwvxg052q324vrwp4p7nz0wh04za"))))
(build-system cmake-build-system)
(inputs
`(("libexif" ,libexif)
@@ -979,10 +1052,7 @@ manager Compton.")
("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
(synopsis "The image viewer and screenshot tool for lxqt")
(description "LXImage-Qt is the Qt port of LXImage, a simple and fast
@@ -992,14 +1062,14 @@ image viewer.")
(define-public obconf-qt
(package
(name "obconf-qt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1fbzn1p2mdvn8dcbavmd1imrvkph2jfssrlw8l26qz6qk8qlmhnf"))))
+ (base32 "1kzb7364150b60qd3wcgnw78b9ia5k3b16kq8w3p1y7pg6pddy8m"))))
(build-system cmake-build-system)
(inputs
`(("imlib2" ,imlib2)
@@ -1017,10 +1087,7 @@ image viewer.")
("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
(synopsis "Openbox configuration tool")
(description "ObConf-Qt is a Qt port of ObConf, a configuration editor for
@@ -1030,14 +1097,14 @@ window manager OpenBox.")
(define-public pavucontrol-qt
(package
(name "pavucontrol-qt")
- (version "0.4.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
+ (base32 "18mw5r8grfrf95vxjbqrr790kl5l59qdqcmlxmwa6rwbfgywj1fq"))))
(build-system cmake-build-system)
(inputs
`(("glib" ,glib)
@@ -1050,10 +1117,7 @@ window manager OpenBox.")
("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
(synopsis "Pulseaudio mixer in Qt")
(description "@code{pavucontrol-qt} is the Qt port of volume control
@@ -1063,21 +1127,22 @@ window manager OpenBox.")
(define-public qps
(package
(name "qps")
- (version "1.10.18")
+ (version "1.10.20")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0pzk83p7a9ax0893s9hp2qkmiilzrf8iqry5a0x1g73hdwm5hm44"))))
+ (base32 "0dz7ricxg2rrmdyca6mc2d4lyy5bpksjk751hvn95wssr76y2w0m"))))
(build-system cmake-build-system)
(inputs
`(("libxrender" ,libxrender)
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(native-inputs
- `(("qttools" ,qttools)))
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
(arguments
'(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
@@ -1089,14 +1154,14 @@ processes currently in existence, much like code{top} or code{ps}.")
(define-public qtermwidget
(package
(name "qtermwidget")
- (version "0.9.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1c1qzbysxjbikp4bpgphphw4dgpl10gz8m06ccs2c48qxhpyd773"))))
+ (base32 "0v1vvi8vf9y8nv8y0gzffaqji53s75ab5jypksih0ndcws8ryww4"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)))
@@ -1104,10 +1169,7 @@ processes currently in existence, much like code{top} or code{ps}.")
`(("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
(synopsis "The terminal widget for QTerminal")
(description "QTermWidget is a terminal emulator widget for Qt 5.")
@@ -1116,14 +1178,14 @@ processes currently in existence, much like code{top} or code{ps}.")
(define-public qterminal
(package
(name "qterminal")
- (version "0.9.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1vlza75br1ys62lgkdz26md729bfpbnasfzswp7hakmgaq1rhms1"))))
+ (base32 "0cgyaskyqginmm85d11inbi0mmxrsrnvgyx6g4l4l4iqpphfq670"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -1133,10 +1195,7 @@ processes currently in existence, much like code{top} or code{ps}.")
`(("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ '(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
(synopsis "Lightweight Qt-based terminal emulator")
(description "QTerminal is a lightweight Qt terminal emulator based on
@@ -1146,14 +1205,14 @@ QTermWidget.")
(define-public screengrab
(package
(name "screengrab")
- (version "1.99")
+ (version "1.101")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/screengrab/releases/download/"
version "/screengrab-" version ".tar.xz"))
(sha256
- (base32 "17y8rsx9fixvxv2byq8d6c01vry10nv07f8jy85vz7zp4f0rgzz3"))))
+ (base32 "05f81xjlmiykd7iwx5xns5vnynjq4js4x1bk8wd648frrksp44fa"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)