summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index d0cdefd533..fc5ddc9cda 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -41,13 +41,13 @@
#:phases
(alist-replace
'unpack
- (lambda* (#:key source name version #:allow-other-keys)
+ (lambda* (#:key source #:allow-other-keys)
(let ((unpack (assoc-ref %standard-phases 'unpack)))
- (apply unpack (list #:source source))
- (apply unpack (list #:source (car (find-files "." "\\.tar$"))))))
+ (unpack #:source source)
+ (unpack #:source (car (find-files "." "\\.tar$")))))
(alist-replace
'configure
- (lambda* (#:key #:allow-other-keys)
+ (lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
(system* "./Configure" "linux"))