summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm31
1 files changed, 9 insertions, 22 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 06a1905479..7e07f4dd67 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,7 +77,7 @@ staying as close to their API as is reasonable.")
(define-public glog
(package
(name "glog")
- (version "0.4.0")
+ (version "0.5.0")
(home-page "https://github.com/google/glog")
(source (origin
(method git-fetch)
@@ -84,24 +85,12 @@ staying as close to their API as is reasonable.")
(commit (string-append "v" version))))
(sha256
(base32
- "1xd3maiipfbxmhc9rrblc5x52nxvkwxp14npg31y5njqvkvzax9b"))
+ "17014q25c99qyis6l3fwxidw6222bb269fdlr74gn7pzmzg4lvg3"))
(file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-signal-tests
- (lambda _
- ;; XXX: This test fails on non x86_64. See e.g.
- ;; https://github.com/google/glog/issues/219 and
- ;; https://github.com/google/glog/issues/256.
- (substitute* "Makefile"
- (("\tsignalhandler_unittest_sh") "\t$(EMPTY)"))
- #t)))))
+ (build-system cmake-build-system)
(native-inputs
- `(("perl" ,perl) ;for tests
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list perl ;for tests
+ autoconf automake libtool))
(synopsis "C++ logging library")
(description
"Google glog is a library that implements application-level logging.
@@ -124,10 +113,8 @@ command line.")
"0wl2wm6p3pc0vkk33s7rzgcfvs9cwxfmlz997pdfhlw72r00l7s5"))))
(build-system python-build-system)
(inputs
- `(("python-pyyaml" ,python-pyyaml)
- ("python-sockjs-tornado" ,python-sockjs-tornado)
- ("python-tornado-http-auth" ,python-tornado-http-auth)
- ("python-tornado" ,python-tornado)))
+ (list python-pyyaml python-sockjs-tornado python-tornado-http-auth
+ python-tornado))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -179,7 +166,7 @@ commands, displaying the results via a web interface.")
#t))
(delete 'configure)) ; no configure script
#:tests? #f)) ; no test suite (make check just runs cppcheck)
- (inputs `(("ncurses" ,ncurses)))
+ (inputs (list ncurses))
(home-page "https://vanheusden.com/multitail/")
(synopsis "Monitor multiple log files")
(description