summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 844baf15ae..34edea41de 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6700,3 +6700,43 @@ also makes it easy to shift paradigms when necessary - the usual Lisp control
constructs can be used interchangeably with pattern matching, and the full
power of CXML is available when necessary.")
(license license:bsd-3))))
+
+;; TODO: dbus uses ASDF's package-inferred-system which is not supported by
+;; asdf-build-system/sbcl as of 2019-08-02. We should fix
+;; asdf-build-system/sbcl.
+(define-public cl-dbus
+ (let ((commit "24b452df3a45ca5dc95015500f34baad175c981a")
+ (revision "1"))
+ (package
+ (name "cl-dbus")
+ (build-system asdf-build-system/source)
+ (version (git-version "20190408" revision commit))
+ (home-page "https://github.com/death/dbus")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
+ ;; Inputs must be propagated or else packages depending on this won't have the necessary packages.
+ (propagated-inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("trivial-garbage" ,sbcl-trivial-garbage)
+ ("babel" ,sbcl-babel)
+ ("iolib" ,sbcl-iolib)
+ ("iolib+multiplex" ,(@@ (gnu packages lisp) sbcl-iolib+multiplex))
+ ("iolib+syscalls" ,(@@ (gnu packages lisp) sbcl-iolib+syscalls))
+ ("iolib+streams" ,(@@ (gnu packages lisp) sbcl-iolib+streams))
+ ("iolib+sockets" ,(@@ (gnu packages lisp) sbcl-iolib+sockets))
+ ("ieee-floats" ,sbcl-ieee-floats)
+ ("flexi-streams" ,sbcl-flexi-streams)
+ ("cl-xmlspam" ,sbcl-cl-xmlspam)
+ ("ironclad" ,sbcl-ironclad)))
+ (synopsis "D-Bus client library for Common Lisp")
+ (description "This is a Common Lisp library that allows to publish D-Bus
+objects as well as send and notify other objects connected to a bus.")
+ (license license:bsd-2))))