summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 16dbad904b..0065f56e7e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5181,6 +5181,12 @@ port within a range.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-python3-path
+ (lambda _
+ (substitute* "src/callpython.lisp"
+ (("\\*python-command\\* \"python\"")
+ (string-append "*python-command* "
+ "\"" (which "python3") "\"")))))
(add-after 'unpack 'replace-*base-directory*-var
(lambda* (#:key outputs #:allow-other-keys)
;; In the ASD, the author makes an attempt to