summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm185
1 files changed, 136 insertions, 49 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d990212115..91d16fb594 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -204,11 +204,12 @@ implementation with no external dependencies.")
(package
(name "sbcl-golden-utils")
(version (git-version "0.0.0" revision commit))
+ (home-page "https://github.com/mfiano/mfiano-utils")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://git.mfiano.net/mfiano/golden-utils")
+ (url home-page)
(commit commit)))
(file-name (git-file-name "golden-utils" version))
(sha256
@@ -216,7 +217,6 @@ implementation with no external dependencies.")
(build-system asdf-build-system/sbcl)
(inputs
`(("alexandria" ,sbcl-alexandria)))
- (home-page "https://git.mfiano.net/mfiano/golden-utils")
(synopsis "Common Lisp utility library")
(description
"This is a Common Lisp library providing various utilities.")
@@ -1813,8 +1813,8 @@ that of Eos has not. Thus, Eos is now deprecated in favor of FiveAM.")
(sbcl-package->ecl-package sbcl-eos))
(define-public sbcl-esrap
- (let ((commit "da6b24fb18bdb8e7e177bcf2820cdaf0b560deb6")
- (revision "1"))
+ (let ((commit "866f28fa7a2c1d3fb6d0d0423850d1f9d955750f")
+ (revision "2"))
(package
(name "sbcl-esrap")
(version (git-version "0.18" revision commit))
@@ -1825,13 +1825,15 @@ that of Eos has not. Thus, Eos is now deprecated in favor of FiveAM.")
(url "https://github.com/scymtym/esrap")
(commit commit)))
(sha256
- (base32 "12vf3bxwzf8icnf6rw1xalvm7493cfbb46r2vlhc09s59djkf39q"))
+ (base32 "19rb3dmpw3csqqagmrf80dpk5d2qn0l7fpfmxx5zwdnjk367kbwg"))
(file-name (git-file-name "esrap" version))))
(build-system asdf-build-system/sbcl)
(native-inputs
`(("fiveam" ,sbcl-fiveam)))
(inputs
- `(("alexandria" ,sbcl-alexandria)))
+ `(("alexandria" ,sbcl-alexandria)
+ ("trivial-with-current-source-form"
+ ,sbcl-trivial-with-current-source-form)))
(synopsis "Common Lisp packrat parser")
(description
"This is a packrat parser for Common Lisp.
@@ -2132,7 +2134,7 @@ also be supported.")
(define-public sbcl-ironclad
(package
(name "sbcl-ironclad")
- (version "0.55")
+ (version "0.56")
(source
(origin
(method git-fetch)
@@ -2140,7 +2142,7 @@ also be supported.")
(url "https://github.com/sharplispers/ironclad/")
(commit (string-append "v" version))))
(sha256
- (base32 "1w4slnc4143w1gcff1wxsivzb8kcji0bpd7y9rld3sabay0qprwl"))
+ (base32 "0dhakily94vswl8a6q9ad0af8nk4pnvfgx7sw9kxl1wdq1pkg3ni"))
(file-name (git-file-name name version))))
(build-system asdf-build-system/sbcl)
(native-inputs
@@ -3455,43 +3457,57 @@ is a library for creating graphical user interfaces.")
(sbcl-package->ecl-package sbcl-cl-cffi-gtk))
(define-public sbcl-cl-webkit
- (let ((commit "cfc4f01ee806169d824750b4014653a93af9353d"))
- (package
- (name "sbcl-cl-webkit")
- (version (git-version "2.4" "16" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joachifm/cl-webkit")
- (commit commit)))
- (file-name (git-file-name "cl-webkit" version))
- (sha256
- (base32
- "18n90m33bi6arnjmwr3q3m0arwzr0kdnydlv4if82crvaagd6m89"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("cffi" ,sbcl-cffi)
- ("cl-cffi-gtk" ,sbcl-cl-cffi-gtk)
- ("webkitgtk" ,webkitgtk)))
- (arguments
- `(#:asd-systems '("cl-webkit2")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "webkit2/webkit2.init.lisp"
- (("libwebkit2gtk" all)
- (string-append
- (assoc-ref inputs "webkitgtk") "/lib/" all))))))))
- (home-page "https://github.com/joachifm/cl-webkit")
- (synopsis "Binding to WebKitGTK+ for Common Lisp")
- (description
- "@command{cl-webkit} is a binding to WebKitGTK+ for Common Lisp,
+ (package
+ (name "sbcl-cl-webkit")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joachifm/cl-webkit")
+ (commit version)))
+ (file-name (git-file-name "cl-webkit" version))
+ (sha256
+ (base32
+ "015xry1cvbgspfzz35ifz2qscz946ljhj2z8rzjscy9v8fgnjsdk"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("cl-cffi-gtk" ,sbcl-cl-cffi-gtk)
+ ("webkitgtk" ,webkitgtk)))
+ (native-inputs
+ `(;; Tests seem to need Xorg.
+ ;; ("xorg-server" ,xorg-server-for-tests)
+ ("calispel" ,sbcl-calispel)
+ ("fiveam" ,sbcl-fiveam)
+ ("float-features" ,sbcl-float-features)))
+ (arguments
+ `(#:asd-systems '("cl-webkit2")
+ #:tests? #f ; TODO: Tests hang, why?
+ #:phases
+ (modify-phases %standard-phases
+ ;; The following phase is needed for tests:
+ ;; (add-before 'check 'start-xorg-server
+ ;; (lambda* (#:key inputs #:allow-other-keys)
+ ;; ;; The test suite requires a running X server.
+ ;; (system (string-append (assoc-ref inputs "xorg-server")
+ ;; "/bin/Xvfb :1 &"))
+ ;; (setenv "DISPLAY" ":1")
+ ;; #t))
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "webkit2/webkit2.init.lisp"
+ (("libwebkit2gtk" all)
+ (string-append
+ (assoc-ref inputs "webkitgtk") "/lib/" all))))))))
+ (home-page "https://github.com/joachifm/cl-webkit")
+ (synopsis "Binding to WebKitGTK+ for Common Lisp")
+ (description
+ "@command{cl-webkit} is a binding to WebKitGTK+ for Common Lisp,
currently targeting WebKit version 2. The WebKitGTK+ library adds web
browsing capabilities to an application, leveraging the full power of the
WebKit browsing engine.")
- (license license:expat))))
+ (license license:expat)))
(define-public cl-webkit
(sbcl-package->cl-source-package sbcl-cl-webkit))
@@ -3628,7 +3644,7 @@ Lisp, featuring:
"Markup allows the use of HTML syntax with in Common Lisp code.
This has the advantage of being able to copy HTML snippets and have them
instantly be functional, less double quotes than a s-expression approach,
-and designers will be able to understand the embeded HTML.")
+and designers will be able to understand the embedded HTML.")
(license license:asl2.0))))
(define-public ecl-markup-reader
@@ -4275,7 +4291,7 @@ sockets, SSL, continuable uploads, file uploads, cookies, and more.")
(define-public sbcl-hunchentoot
(package
(name "sbcl-hunchentoot")
- (version "1.2.38")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -4284,7 +4300,7 @@ sockets, SSL, continuable uploads, file uploads, cookies, and more.")
(commit (string-append "v" version))))
(file-name (git-file-name "hunchentoot" version))
(sha256
- (base32 "1anpcad7w045m4rsjs1f3xdhjwx5cppq1h0vlb3q7dz81fi3i6yq"))))
+ (base32 "1z0m45lp6rv59g69l44gj3q3d2bmjlhqzpii0vgkniam21dcimy9"))))
(build-system asdf-build-system/sbcl)
(native-inputs
`(("sbcl-cl-who" ,sbcl-cl-who)
@@ -5524,6 +5540,39 @@ the CFFI approach used by burgled-batteries, but has the same goal.")
(define-public ecl-py4cl
(sbcl-package->ecl-package sbcl-py4cl))
+(define-public sbcl-schemeish
+ (let ((commit "dff57bafae5d0cffa104c8fdc4146502f32d7f85")
+ (revision "1"))
+ (package
+ (name "sbcl-schemeish")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chebert/schemeish")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q9b07spmhg1b576cnnacvkf7zr3mab2rdydfylbn92y9mms9vyj"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("trivial-arguments" ,sbcl-trivial-arguments)))
+ (synopsis "Scheme style syntax/macros/functions for Common Lisp")
+ (description
+ "Schemeish implements several useful Scheme constructs for Common Lisp.
+These include named-let, define, scheme argument lists, and a shortcut to
+FUNCALL with [] instead of ().")
+ (home-page "https://github.com/chebert/schemeish")
+ ;; MIT License
+ (license license:expat))))
+
+(define-public cl-schemeish
+ (sbcl-package->cl-source-package sbcl-schemeish))
+
+(define-public ecl-schemeish
+ (sbcl-package->ecl-package sbcl-schemeish))
+
(define-public sbcl-parse-declarations
(let ((commit "549aebbfb9403a7fe948654126b9c814f443f4f2")
(revision "1"))
@@ -5608,7 +5657,9 @@ high-level way. This library provides such operators.")
(file-name (git-file-name name version))
(sha256
(base32
- "1nzn7jawrfajyzwfnzrg2cmn9xxadcqh4szbpg0jggkhdkdzz4wa"))))
+ "1nzn7jawrfajyzwfnzrg2cmn9xxadcqh4szbpg0jggkhdkdzz4wa"))
+ (patches
+ (search-patches "sbcl-burgled-batteries3-fix-signals.patch"))))
(build-system asdf-build-system/sbcl)
(arguments
`(#:tests? #f
@@ -9352,7 +9403,9 @@ for reading and writing JPEG image files.")
(commit commit)))
(file-name (git-file-name "cl-png" version))
(sha256
- (base32 "173hqwpd0rwqf95mfx1h9l9c3i8bb0gvnpspzmmz3g5x3440czy4"))))
+ (base32 "173hqwpd0rwqf95mfx1h9l9c3i8bb0gvnpspzmmz3g5x3440czy4"))
+ ;; Patch to fix compiling with SBCL >= 2.1.6.
+ (patches (search-patches "sbcl-png-fix-sbcl-compatibility.patch"))))
(build-system asdf-build-system/sbcl)
(arguments
`(#:phases
@@ -10713,6 +10766,36 @@ If features:
(define-public ecl-sycamore
(sbcl-package->ecl-package sbcl-sycamore))
+(define-public sbcl-funds
+ (let ((commit "39d425818876b898c20780a678803df506df8424")
+ (revision "2"))
+ (package
+ (name "sbcl-funds")
+ (version (git-version "1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charJe/funds")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13y1jhvnpzrs9daz6f3z67w6h2y21ggb10j3j4vnc5p3m8i7ps4p"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Purely functional data structure library in Common Lisp")
+ (description
+ "Funds provides portable, purely functional data structures in Common
+Lisp. It includes tree based implementations for Array, Hash, Queue, Stack, and
+Heap.")
+ (home-page "https://common-lisp.net/project/funds/")
+ (license license:asl2.0))))
+
+(define-public cl-funds
+ (sbcl-package->cl-source-package sbcl-funds))
+
+(define-public ecl-funds
+ (sbcl-package->ecl-package sbcl-funds))
+
(define-public sbcl-trivial-package-local-nicknames
(package
(name "sbcl-trivial-package-local-nicknames")
@@ -17845,7 +17928,11 @@ Common Lisp based on the hash array-mapped trie data structure.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/mdbergmann/cl-gserver")
- (commit version)))
+
+ ;; The "1.8.0" tag must have been moved from
+ ;; c83d92a66102faa514b546029a9bd2078b95dc0f to
+ ;; 90832f02f0556463e332cd055c3c1be58f323aea, 22 commits later!
+ (commit "c83d92a66102faa514b546029a9bd2078b95dc0f")))
(file-name (git-file-name "cl-gserver" version))
(sha256
(base32 "1bfz7z8v417dvsp1jz76ir3ihcs8g7zis2d56xx1dpzqzjd95g7z"))))
@@ -18510,7 +18597,7 @@ customizable errors.")
(home-page "https://github.com/interactive-ssr/hunchenissr")
(synopsis "Interactive Server Side Rendering backend for Hunchentoot")
(description
- "Hunchenissr works together with issr.js for the develpment of
+ "Hunchenissr works together with issr.js for the development of
interactive (changing without page refreshes) websites making use of websocket
and Common Lisp server HTML generation instead of mountains of convoluted
Javascript.")