summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm907
1 files changed, 162 insertions, 745 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cee2bbe37b..6521a1add3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
+ #:use-module (gnu packages lisp-check)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
@@ -333,37 +334,6 @@ or cl-launch for portable processing of command-line arguments.")
(define-public cl-command-line-arguments
(sbcl-package->cl-source-package sbcl-command-line-arguments))
-(define-public sbcl-fiveam
- (package
- (name "sbcl-fiveam")
- (version "1.4.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sionescu/fiveam")
- (commit (string-append "v" version))))
- (file-name (git-file-name "fiveam" version))
- (sha256
- (base32 "04mh5plmlb15jbq3dkd8b9jl1dmbbg4hnd3k7859vpf6s12k5p4j"))))
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("net.didierverna.asdf-flv" ,sbcl-net.didierverna.asdf-flv)
- ("trivial-backtrace" ,sbcl-trivial-backtrace)))
- (build-system asdf-build-system/sbcl)
- (synopsis "Common Lisp testing framework")
- (description "FiveAM is a simple (as far as writing and running tests
-goes) regression testing framework. It has been designed with Common Lisp's
-interactive development model in mind.")
- (home-page "https://common-lisp.net/project/fiveam/")
- (license license:bsd-3)))
-
-(define-public cl-fiveam
- (sbcl-package->cl-source-package sbcl-fiveam))
-
-(define-public ecl-fiveam
- (sbcl-package->ecl-package sbcl-fiveam))
-
(define-public sbcl-cl-irc
(let ((commit "963823537c7bfcda2edd4c44d172192da6722175")
(revision "0"))
@@ -512,42 +482,6 @@ thin compatibility layer for gray streams.")
(define-public ecl-trivial-gray-streams
(sbcl-package->ecl-package sbcl-trivial-gray-streams))
-(define-public sbcl-fiasco
- (let ((commit "d62f7558b21addc89f87e306f65d7f760632655f")
- (revision "1"))
- (package
- (name "sbcl-fiasco")
- (version (git-version "0.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joaotavora/fiasco")
- (commit commit)))
- (file-name (git-file-name "fiasco" version))
- (sha256
- (base32
- "1zwxs3d6iswayavcmb49z2892xhym7n556d8dnmvalc32pm9bkjh"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
- (synopsis "Simple and powerful test framework for Common Lisp")
- (description "A Common Lisp test framework that treasures your failures,
-logical continuation of Stefil. It focuses on interactive debugging.")
- (home-page "https://github.com/joaotavora/fiasco")
- ;; LICENCE specifies this is public-domain unless the legislation
- ;; doesn't allow or recognize it. In that case it falls back to a
- ;; permissive licence.
- (license (list license:public-domain
- (license:x11-style "file://LICENCE"))))))
-
-(define-public cl-fiasco
- (sbcl-package->cl-source-package sbcl-fiasco))
-
-(define-public ecl-fiasco
- (sbcl-package->ecl-package sbcl-fiasco))
-
(define-public sbcl-flexi-streams
(package
(name "sbcl-flexi-streams")
@@ -1427,38 +1361,6 @@ documentation system, explicit development support, etc.")
(define-public ecl-hu.dwim.asdf
(sbcl-package->ecl-package sbcl-hu.dwim.asdf))
-(define-public sbcl-hu.dwim.stefil
- (let ((commit "414902c6f575818c39a8a156b8b61b1adfa73dad"))
- (package
- (name "sbcl-hu.dwim.stefil")
- (version (git-version "0.0.0" "2" commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/hu-dwim/hu.dwim.stefil")
- (commit commit)))
- (sha256
- (base32 "14izmjjim590rh74swrssavdmdznj2z8vhqixy780sjhpcr5pmkc"))
- (file-name (git-file-name "hu.dwim.stefil" version))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("asdf:cl-hu.dwim.asdf" ,sbcl-hu.dwim.asdf)))
- (inputs
- `(("sbcl-alexandria" ,sbcl-alexandria)))
- (home-page "http://dwim.hu/project/hu.dwim.stefil")
- (synopsis "Simple test framework")
- (description "Stefil is a simple test framework for Common Lisp,
-with a focus on interactive development.")
- (license license:public-domain))))
-
-(define-public cl-hu.dwim.stefil
- (sbcl-package->cl-source-package sbcl-hu.dwim.stefil))
-
-(define-public ecl-hu.dwim.stefil
- (sbcl-package->ecl-package sbcl-hu.dwim.stefil))
-
(define-public sbcl-babel
;; No release since 2014.
(let ((commit "aeed2d1b76358db48e6b70a64399c05678a6b9ea"))
@@ -1785,36 +1687,6 @@ libraries such as Bordeaux-Threads and Eager Future.")
(define-public ecl-calispel
(sbcl-package->ecl-package sbcl-calispel))
-(define-public sbcl-eos
- (let ((commit "b4413bccc4d142cbe1bf49516c3a0a22c9d99243")
- (revision "2"))
- (package
- (name "sbcl-eos")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/adlai/Eos")
- (commit commit)))
- (sha256
- (base32 "1afllvmlnx97yzz404gycl3pa3kwx427k3hrbf37rpmjlv47knhk"))
- (file-name (git-file-name "eos" version))))
- (build-system asdf-build-system/sbcl)
- (synopsis "Unit Testing for Common Lisp")
- (description
- "Eos was a unit testing library for Common Lisp.
-It began as a fork of FiveAM; however, FiveAM development has continued, while
-that of Eos has not. Thus, Eos is now deprecated in favor of FiveAM.")
- (home-page "https://github.com/adlai/Eos")
- (license license:expat))))
-
-(define-public cl-eos
- (sbcl-package->cl-source-package sbcl-eos))
-
-(define-public ecl-eos
- (sbcl-package->ecl-package sbcl-eos))
-
(define-public sbcl-esrap
(let ((commit "866f28fa7a2c1d3fb6d0d0423850d1f9d955750f")
(revision "2"))
@@ -2060,34 +1932,6 @@ than the body of the lambda.")
(define-public cl-fn
(sbcl-package->cl-source-package sbcl-fn))
-(define-public sbcl-rt
- (let ((commit "a6a7503a0b47953bc7579c90f02a6dba1f6e4c5a")
- (revision "1"))
- (package
- (name "sbcl-rt")
- (version (git-version "1990.12.19" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://git.kpe.io/rt.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13si2rrxaagbr0bkvg6sqicxxpyshabx6ad6byc9n2ik5ysna69b"))))
- (build-system asdf-build-system/sbcl)
- (synopsis "MIT Regression Tester")
- (description
- "RT provides a framework for writing regression test suites.")
- (home-page "https://www.cliki.net/rt")
- (license license:expat))))
-
-(define-public cl-rt
- (sbcl-package->cl-source-package sbcl-rt))
-
-(define-public ecl-rt
- (sbcl-package->ecl-package sbcl-rt))
-
(define-public sbcl-nibbles
;; No tagged release since 2018.
(let ((commit "dad25240928d5cf8f7df69c4398244e03570bb35")
@@ -2388,35 +2232,6 @@ project.")
(define-public cl-mssql
(sbcl-package->cl-source-package sbcl-mssql))
-(define-public sbcl-lisp-unit
- (let ((commit "89653a232626b67400bf9a941f9b367da38d3815"))
- (package
- (name "sbcl-lisp-unit")
- (version (git-version "0.0.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OdonataResearchLLC/lisp-unit")
- (commit commit)))
- (sha256
- (base32
- "0p6gdmgr7p383nvd66c9y9fp2bjk4jx1lpa5p09g43hr9y9pp9ry"))
- (file-name (git-file-name "lisp-unit" version))))
- (build-system asdf-build-system/sbcl)
- (synopsis "Common Lisp Test framework inspired by JUnit to be simple of use")
- (description
- "@command{lisp-unit} is a Common Lisp library that supports unit
-testing. It is an extension of the library written by Chris Riesbeck.")
- (home-page "https://github.com/OdonataResearchLLC/lisp-unit")
- (license license:expat))))
-
-(define-public cl-lisp-unit
- (sbcl-package->cl-source-package sbcl-lisp-unit))
-
-(define-public ecl-lisp-unit
- (sbcl-package->ecl-package sbcl-lisp-unit))
-
(define-public sbcl-anaphora
(package
(name "sbcl-anaphora")
@@ -2448,47 +2263,6 @@ new fiends in addition to old friends like @command{aif} and
(define-public ecl-anaphora
(sbcl-package->ecl-package sbcl-anaphora))
-(define-public sbcl-lift
- (let ((commit "2594160d6ca3a77d8750110dfa63214256aab852")
- (revision "2"))
- (package
- (name "sbcl-lift")
- (version (git-version "1.7.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gwkkwg/lift")
- (commit commit)))
- (sha256
- (base32 "01xvz9sl5l5lai4h9dabmcjnm659wf5zllaxqbs55lffskp6jwq3"))
- (file-name (git-file-name "lift" version))
- (modules '((guix build utils)))
- (snippet
- ;; Don't keep the bundled website
- `(begin
- (delete-file-recursively "website")
- #t))))
- (build-system asdf-build-system/sbcl)
- (arguments
- ;; The tests require a debugger, but we run with the debugger disabled.
- '(#:tests? #f))
- (synopsis "LIsp Framework for Testing")
- (description
- "The LIsp Framework for Testing (LIFT) is a unit and system test tool for LISP.
-Though inspired by SUnit and JUnit, it's built with Lisp in mind. In LIFT,
-testcases are organized into hierarchical testsuites each of which can have
-its own fixture. When run, a testcase can succeed, fail, or error. LIFT
-supports randomized testing, benchmarking, profiling, and reporting.")
- (home-page "https://github.com/gwkkwg/lift")
- (license license:expat))))
-
-(define-public cl-lift
- (sbcl-package->cl-source-package sbcl-lift))
-
-(define-public ecl-lift
- (sbcl-package->ecl-package sbcl-lift))
-
(define-public sbcl-let-plus
(let ((commit "5f14af61d501ecead02ec6b5a5c810efc0c9fdbb"))
(package
@@ -2609,49 +2383,6 @@ named color.")
(define-public ecl-cl-ansi-text
(sbcl-package->ecl-package sbcl-cl-ansi-text))
-(define-public sbcl-prove
- (let ((commit "5d71f02795b89e36f34e8c7d50e69b67ec6ca2de")
- (revision "2"))
- (package
- (name "sbcl-prove")
- (version (git-version "1.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fukamachi/prove")
- (commit commit)))
- (sha256
- (base32 "0ca6ha3zhmckq3ad9lxm6sbg4i0hg3m81xhan4dkxd3x9898jzpc"))
- (file-name (git-file-name "prove" version))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("cl-colors" ,sbcl-cl-colors)
- ("cl-ppcre" ,sbcl-cl-ppcre)
- ("cl-ansi-text" ,sbcl-cl-ansi-text)))
- (synopsis "Yet another unit testing framework for Common Lisp")
- (description
- "This project was originally called @command{cl-test-more}.
-@command{prove} is yet another unit testing framework for Common Lisp. The
-advantages of @command{prove} are:
-
-@itemize
-@item Various simple functions for testing and informative error messages
-@item ASDF integration
-@item Extensible test reporters
-@item Colorizes the report if it's available (note for SLIME)
-@item Reports test durations
-@end itemize\n")
- (home-page "https://github.com/fukamachi/prove")
- (license license:expat))))
-
-(define-public cl-prove
- (sbcl-package->cl-source-package sbcl-prove))
-
-(define-public ecl-prove
- (sbcl-package->ecl-package sbcl-prove))
-
(define-public sbcl-proc-parse
(let ((commit "ac3636834d561bdc2686c956dbd82494537285fd"))
(package
@@ -2773,35 +2504,6 @@ utilities that make it even easier to manipulate text in Common Lisp. It has
(define-public ecl-cl-string-match
(sbcl-package->ecl-package sbcl-cl-string-match))
-(define-public sbcl-ptester
- (let ((commit "fe69fde54f4bce00ce577feb918796c293fc7253")
- (revision "1"))
- (package
- (name "sbcl-ptester")
- (version (git-version "2.1.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://git.kpe.io/ptester.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1l0lfl7cdnr2qf4zh38hi4llxg22c49zkm639bdkmvlkzwj3ndwf"))))
- (build-system asdf-build-system/sbcl)
- (home-page "http://quickdocs.org/ptester/")
- (synopsis "Portable test harness package")
- (description
- "@command{ptester} is a portable testing framework based on Franz's
-tester module.")
- (license license:llgpl))))
-
-(define-public cl-ptester
- (sbcl-package->cl-source-package sbcl-ptester))
-
-(define-public ecl-ptester
- (sbcl-package->ecl-package sbcl-ptester))
-
(define-public sbcl-puri
(let ((commit "4bbab89d9ccbb26346899d1f496c97604fec567b")
(revision "2"))
@@ -3191,6 +2893,59 @@ relational database engine.")
(define-public ecl-cl-sqlite
(sbcl-package->ecl-package sbcl-cl-sqlite))
+(define-public sbcl-cl-redis
+ (let ((commit "7d592417421cf7cd1cffa96043b457af0490df7d")
+ (revision "0"))
+ (package
+ (name "sbcl-cl-redis")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vseloved/cl-redis")
+ (commit commit)))
+ (file-name (git-file-name "cl-redis" version))
+ (sha256
+ (base32 "0x5ahxb5cx37biyn3cjycshhm1rr9p5cf1a9l5hd1n1xjxm2f8vi"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-redis
+ (lambda _
+ (system "redis-server --port 6379 &"))))))
+ (native-inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("flexi-streams" ,sbcl-flexi-streams)
+ ("redis" ,redis)
+ ("should-test" ,sbcl-should-test)))
+ (inputs
+ `(("babel" ,sbcl-babel)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("flexi-streams" ,sbcl-flexi-streams)
+ ("rutils" ,sbcl-rutils)
+ ("usocket" ,sbcl-usocket)))
+ (home-page "https://github.com/vseloved/cl-redis")
+ (synopsis "Common Lisp client for Redis")
+ (description "This is a Common Lisp wrapper for interacting with the
+Redis data structure store.")
+ (license license:expat))))
+
+(define-public cl-redis
+ (sbcl-package->cl-source-package sbcl-cl-redis))
+
+(define-public ecl-cl-redis
+ (let ((pkg (sbcl-package->ecl-package sbcl-cl-redis)))
+ (package
+ (inherit pkg)
+ (arguments
+ (substitute-keyword-arguments (package-arguments pkg)
+ ;; Tests are failing on ECL with:
+ ;; Test L-COMMANDS: An error occurred during initialization:
+ ;; Protocol not found: "tcp".
+ ((#:tests? _ #f) #f))))))
+
(define-public sbcl-parenscript
;; Source archives are overwritten on every release, we use the Git repo instead.
(let ((commit "7a1ac46353cecd144fc91915ba9f122aafcf4766"))
@@ -4755,48 +4510,6 @@ Only minimal changes required to make your CLOS objects serializable.")
(define-public ecl-marshal
(sbcl-package->ecl-package sbcl-marshal))
-(define-public sbcl-checkl
- (let ((commit "80328800d047fef9b6e32dfe6bdc98396aee3cc9")
- (revision "1"))
- (package
- (name "sbcl-checkl")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rpav/CheckL")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0bpisihx1gay44xmyr1dmhlwh00j0zzi04rp9fy35i95l2r4xdlx"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- ;; Error while trying to load definition for system checkl-test from
- ;; pathname [...]/checkl-test.asd: The function CHECKL:DEFINE-TEST-OP
- ;; is undefined.
- '(#:asd-files '("checkl.asd")
- #:tests? #f))
- (native-inputs
- `(("sbcl-fiveam" ,sbcl-fiveam)))
- (inputs
- `(("sbcl-marshal" ,sbcl-marshal)))
- (home-page "https://github.com/rpav/CheckL/")
- (synopsis "Dynamic testing for Common Lisp")
- (description
- "CheckL lets you write tests dynamically, it checks resulting values
-against the last run.")
- ;; The author specifies both LLGPL and "BSD", but the "BSD" license
- ;; isn't specified anywhere, so I don't know which kind. LLGPL is the
- ;; stronger of the two and so I think only listing this should suffice.
- (license license:llgpl))))
-
-(define-public cl-checkl
- (sbcl-package->cl-source-package sbcl-checkl))
-
-(define-public ecl-checkl
- (sbcl-package->ecl-package sbcl-checkl))
-
(define-public sbcl-fast-io
(let ((commit "603f4903dd74fb221859da7058ae6ca3853fe64b")
(revision "2"))
@@ -5451,39 +5164,6 @@ port within a range.")
(define-public ecl-find-port
(sbcl-package->ecl-package sbcl-find-port))
-(define-public sbcl-clunit
- (let ((commit "6f6d72873f0e1207f037470105969384f8380628")
- (revision "1"))
- (package
- (name "sbcl-clunit")
- (version (git-version "0.2.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tgutu/clunit")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1idf2xnqzlhi8rbrqmzpmb3i1l6pbdzhhajkmhwbp6qjkmxa4h85"))))
- (build-system asdf-build-system/sbcl)
- (synopsis "CLUnit is a Common Lisp unit testing framework")
- (description
- "CLUnit is a Common Lisp unit testing framework. It is designed
-to be easy to use so that you can quickly start testing. CLUnit
-provides a rich set of features aimed at improving your unit testing
-experience.")
- (home-page "https://tgutu.github.io/clunit/")
- ;; MIT License
- (license license:expat))))
-
-(define-public cl-clunit
- (sbcl-package->cl-source-package sbcl-clunit))
-
-(define-public ecl-clunit
- (sbcl-package->ecl-package sbcl-clunit))
-
(define-public sbcl-py4cl
(let ((commit "4c8a2b0814fd311f978964f825ce012290f60136")
(revision "1"))
@@ -5615,37 +5295,6 @@ high-level way. This library provides such operators.")
(define-public ecl-parse-declarations
(sbcl-package->ecl-package sbcl-parse-declarations))
-(define-public sbcl-cl-quickcheck
- (let ((commit "807b2792a30c883a2fbecea8e7db355b50ba662f")
- (revision "1"))
- (package
- (name "sbcl-cl-quickcheck")
- (version (git-version "0.0.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mcandre/cl-quickcheck")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "165lhypq5xkcys6hvzb3jq7ywnmqvzaflda29qk2cbs3ggas4767"))))
- (build-system asdf-build-system/sbcl)
- (synopsis
- "Common Lisp port of the QuickCheck unit test framework")
- (description
- "Common Lisp port of the QuickCheck unit test framework")
- (home-page "https://github.com/mcandre/cl-quickcheck")
- ;; MIT
- (license license:expat))))
-
-(define-public cl-quickcheck
- (sbcl-package->cl-source-package sbcl-cl-quickcheck))
-
-(define-public ecl-cl-quickcheck
- (sbcl-package->ecl-package sbcl-cl-quickcheck))
-
(define-public sbcl-burgled-batteries3
(let ((commit "f65f454d13bb6c40e17e9ec62e41eb5069e09760")
(revision "2"))
@@ -7087,44 +6736,6 @@ decisions becomes significantly easier.")
(define-public ecl-cl-containers
(sbcl-package->ecl-package sbcl-cl-containers))
-(define-public sbcl-xlunit
- (let ((commit "3805d34b1d8dc77f7e0ee527a2490194292dd0fc")
- (revision "1"))
- (package
- (name "sbcl-xlunit")
- (version (git-version "0.6.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://git.kpe.io/xlunit.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0argfmp9nghs4sihyj3f8ch9qfib2b7ll07v5m9ziajgzsfl5xw3"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* "xlunit.asd"
- ((" :force t") ""))
- #t)))))
- (synopsis "Unit testing package for Common Lisp")
- (description
- "The XLUnit package is a toolkit for building test suites. It is based
-on the XPTest package by Craig Brozensky and the JUnit package by Kent Beck.")
- (home-page "http://quickdocs.org/xlunit/")
- (license license:bsd-3))))
-
-(define-public cl-xlunit
- (sbcl-package->cl-source-package sbcl-xlunit))
-
-(define-public ecl-xlunit
- (sbcl-package->ecl-package sbcl-xlunit))
-
(define-public sbcl-cambl
(let ((commit "7016d1a98215f82605d1c158e7a16504ca1f4636")
(revision "1"))
@@ -7735,6 +7346,47 @@ supplement, not a competitor, to Alexandria.")
(define-public ecl-serapeum
(sbcl-package->ecl-package sbcl-serapeum))
+(define-public sbcl-rutils
+ (let ((commit "db3c3f4ae897025b5f0cd81042ca147da60ca0c5")
+ (revision "0"))
+ (package
+ (name "sbcl-rutils")
+ (version (git-version "5.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vseloved/rutils")
+ (commit commit)))
+ (file-name (git-file-name "rutils" version))
+ (sha256
+ (base32 "1d2whscknh1zga2vdqvfqri8wx0gnml3sfqz62igq0ppap6q07y3"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("rutils" "rutilsx")
+ ;; Tests disabled because of a circular dependency with should-test.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ ;; File faild to load, and we don't use it as tests are
+ ;; disabled, so let's delete it.
+ (delete-file "rutilsx-test.asd"))))))
+ (inputs
+ `(("closer-mop" ,sbcl-closer-mop)
+ ("named-readtables" ,sbcl-named-readtables)))
+ (home-page "https://github.com/vseloved/rutils")
+ (synopsis "Radical Utilities for Common Lisp")
+ (description "RUTILS is a syntactic utilities package for Common Lisp.")
+ (license license:bsd-3))))
+
+(define-public cl-rutils
+ (sbcl-package->cl-source-package sbcl-rutils))
+
+(define-public ecl-rutils
+ (sbcl-package->ecl-package sbcl-rutils))
+
(define-public sbcl-arrows
(let ((commit "df7cf0067e0132d9697ac8b1a4f1b9c88d4f5382")
(revision "0"))
@@ -7894,49 +7546,6 @@ JSON interchange format.")
(define-public ecl-yason
(sbcl-package->ecl-package sbcl-yason))
-(define-public sbcl-stefil
- (let ((commit "0398548ec95dceb50fc2c2c03e5fb0ce49b86c7a")
- (revision "0"))
- (package
- (name "sbcl-stefil")
- (version (git-version "0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.common-lisp.net/stefil/stefil.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0bqz64q2szzhf91zyqyssmvrz7da6442rs01808pf3wrdq28bclh"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("iterate" ,sbcl-iterate)
- ("metabang-bind" ,sbcl-metabang-bind)
- ("swank" ,sbcl-slime-swank)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'drop-unnecessary-dependency
- (lambda _
- (substitute* "package.lisp"
- ((":stefil-system") ""))
- #t)))))
- (home-page "https://common-lisp.net/project/stefil/index-old.shtml")
- (synopsis "Simple test framework")
- (description
- "Stefil is a simple test framework for Common Lisp, with a focus on
-interactive development.")
- (license license:public-domain))))
-
-(define-public cl-stefil
- (sbcl-package->cl-source-package sbcl-stefil))
-
-(define-public ecl-stefil
- (sbcl-package->ecl-package sbcl-stefil))
-
(define-public sbcl-graph
(let ((commit "78bf9ec930d8eae4f0861b5be76765fb1e45e24f")
(revision "0"))
@@ -8120,41 +7729,6 @@ macro. This library provides a set of simple utilities to help with that.")
(define-public ecl-form-fiddle
(sbcl-package->ecl-package sbcl-form-fiddle))
-(define-public sbcl-parachute
- (let ((commit "ca04dd8e43010a6dfffa26dbe1d62af86008d666")
- (revision "0"))
- (package
- (name "sbcl-parachute")
- (version (git-version "1.1.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/Shinmera/parachute")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1mvsm3r0r6a2bg75nw0q7n9vlby3ch45qjl7hnb5k1z2n5x5lh60"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("documentation-utils" ,sbcl-documentation-utils)
- ("form-fiddle" ,sbcl-form-fiddle)))
- (synopsis "Extensible and cross-compatible testing framework for Common Lisp")
- (description
- "Parachute is a simple-to-use and extensible testing framework.
-In Parachute, things are organised as a bunch of named tests within a package.
-Each test can contain a bunch of test forms that make up its body.")
- (home-page "https://shinmera.github.io/parachute/")
- (license license:zlib))))
-
-(define-public cl-parachute
- (sbcl-package->cl-source-package sbcl-parachute))
-
-(define-public ecl-parachute
- (sbcl-package->ecl-package sbcl-parachute))
-
(define-public sbcl-array-utils
(let ((commit "f90eb9070d0b2205af51126a35033574725e5c56")
(revision "0"))
@@ -8470,44 +8044,6 @@ and camel-case rules.")
(define-public ecl-symbol-munger
(sbcl-package->ecl-package sbcl-symbol-munger))
-(define-public sbcl-lisp-unit2
- ;; There is a cyclical dependency between symbol-munger and lisp-unit2.
- ;; See https://github.com/AccelerationNet/symbol-munger/issues/4
- (let ((commit "fb9721524d1e4e73abb223ee036d74ce14a5505c")
- (revision "1"))
- (package
- (name "sbcl-lisp-unit2")
- (version (git-version "0.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AccelerationNet/lisp-unit2")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rsqy8y0jqll6xn9a593848f5wvd5ribv4csry1ly0hmdhfnqzlp"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("cl-interpol" ,sbcl-cl-interpol)
- ("iterate" ,sbcl-iterate)
- ("symbol-munger" ,sbcl-symbol-munger)))
- (synopsis "Test Framework for Common Lisp")
- (description
- "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
-style of JUnit for Java. It is a new version of the lisp-unit library written
-by Chris Riesbeck.")
- (home-page "https://github.com/AccelerationNet/lisp-unit2")
- (license license:expat))))
-
-(define-public cl-lisp-unit2
- (sbcl-package->cl-source-package sbcl-lisp-unit2))
-
-(define-public ecl-lisp-unit2
- (sbcl-package->ecl-package sbcl-lisp-unit2))
-
(define-public sbcl-cl-csv
(let ((commit "68ecb5d816545677513d7f6308d9e5e8d2265651")
(revision "2"))
@@ -9294,35 +8830,6 @@ be used with @code{cl-yacc}.")
(define-public ecl-cl-lex
(sbcl-package->ecl-package sbcl-cl-lex))
-(define-public sbcl-clunit2
- (let ((commit "5e28343734eb9b7aee39306a614af92c1062d50b")
- (revision "1"))
- (package
- (name "sbcl-clunit2")
- (version (git-version "0.2.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://notabug.org/cage/clunit2.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ngiapfki6nm8a555mzhb5p7ch79i3w665za5bmb5j7q34fy80vw"))))
- (build-system asdf-build-system/sbcl)
- (synopsis "Unit testing framework for Common Lisp")
- (description
- "CLUnit is a Common Lisp unit testing framework. It is designed to be
-easy to use so that you can quickly start testing.")
- (home-page "https://notabug.org/cage/clunit2")
- (license license:expat))))
-
-(define-public cl-clunit2
- (sbcl-package->cl-source-package sbcl-clunit2))
-
-(define-public ecl-clunit2
- (sbcl-package->ecl-package sbcl-clunit2))
-
(define-public sbcl-cl-colors2
(let ((commit "795aedee593b095fecde574bd999b520dd03ed24")
(revision "1"))
@@ -11269,39 +10776,6 @@ and active restarts.")
(define-public ecl-dissect
(sbcl-package->ecl-package sbcl-dissect))
-(define-public sbcl-rove
- (package
- (name "sbcl-rove")
- (version "0.9.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fukamachi/rove")
- (commit "f3695db08203bf26f3b861dc22ac0f4257d3ec21")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07ala4l2fncxf540fzxj3h5mhi9i4wqllhj0rqk8m2ljl5zbz89q"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("dissect" ,sbcl-dissect)
- ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
- (home-page "https://github.com/fukamachi/rove")
- (synopsis
- "Yet another common lisp testing library")
- (description
- "Rove is a unit testing framework for Common Lisp applications.
-This is intended to be a successor of Prove.")
- (license license:bsd-3)))
-
-(define-public cl-rove
- (sbcl-package->cl-source-package sbcl-rove))
-
-(define-public ecl-rove
- (sbcl-package->ecl-package sbcl-rove))
-
(define-public sbcl-exponential-backoff
(let ((commit "8d9e8444d8b3184a524c12ce3449f91613ab714f"))
(package
@@ -11368,33 +10842,6 @@ learn about each of the parameters.")
(define-public ecl-sxql
(sbcl-package->ecl-package sbcl-sxql))
-(define-public sbcl-1am
- (let ((commit "8b1da94eca4613fd8a20bdf63f0e609e379b0ba5"))
- (package
- (name "sbcl-1am")
- (version (git-version "0.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lmj/1am")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "05ss4nz1jb9kb796295482b62w5cj29msfj8zis33sp2rw2vmv2g"))))
- (build-system asdf-build-system/sbcl)
- (home-page "https://github.com/lmj/1am")
- (synopsis "Minimal testing framework for Common Lisp")
- (description "A minimal testing framework for Common Lisp.")
- (license license:expat))))
-
-(define-public cl-1am
- (sbcl-package->cl-source-package sbcl-1am))
-
-(define-public ecl-1am
- (sbcl-package->ecl-package sbcl-1am))
-
(define-public sbcl-cl-ascii-table
(let ((commit "d9f5e774a56fad1b416e4dadb8f8a5b0e84094e2")
(revision "1"))
@@ -13994,41 +13441,6 @@ latitude/longitude and Open Location Code.")
(define-public ecl-clawk
(sbcl-package->ecl-package sbcl-clawk))
-(define-public sbcl-check-it
- (let ((commit "b79c9103665be3976915b56b570038f03486e62f"))
- (package
- (name "sbcl-check-it")
- (version (git-version "0.1.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/DalekBaldwin/check-it/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kbjwpniffdpv003igmlz5r0vy65m7wpfnhg54fhwirp1227hgg7"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("closer-mop" ,sbcl-closer-mop)
- ("optima" ,sbcl-optima)))
- (native-inputs
- `(("stefil" ,sbcl-stefil)))
- (home-page "https://github.com/arclanguage/Clamp")
- (synopsis "Randomized specification-based testing for Common Lisp")
- (description
- "This is a randomized property-based testing library for Common Lisp.
-Rather than being a full-fledged general test framework in its own right, it's
-designed to embed randomized tests in whatever framework you like.")
- (license license:llgpl))))
-
-(define-public cl-check-it
- (sbcl-package->cl-source-package sbcl-check-it))
-
-(define-public ecl-check-it
- (sbcl-package->ecl-package sbcl-check-it))
-
(define-public sbcl-clamp
(let ((commit "02b8f3953e5753cc61a719807c82f3795cd28fe1"))
(package
@@ -16517,33 +15929,6 @@ color spaces, which supports many color models.")
(define-public cl-dufy
(sbcl-package->cl-source-package sbcl-dufy))
-(define-public sbcl-unit-test
- (let ((commit "266afaf4ac091fe0e8803bac2ae72d238144e735")
- (revision "1"))
- (package
- (name "sbcl-unit-test")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hanshuebner/unit-test")
- (commit commit)))
- (file-name (git-file-name "unit-test" version))
- (sha256
- (base32 "11hpksz56iqkv7jw25p2a8r3n9dj922fyarn16d98589g6hdskj9"))))
- (build-system asdf-build-system/sbcl)
- (home-page "https://github.com/hanshuebner/unit-test")
- (synopsis "Unit-testing framework for Common Lisp")
- (description "This is a unit-testing framework for Common Lisp.")
- (license license:unlicense))))
-
-(define-public ecl-unit-test
- (sbcl-package->ecl-package sbcl-unit-test))
-
-(define-public cl-unit-test
- (sbcl-package->cl-source-package sbcl-unit-test))
-
(define-public sbcl-bknr-datastore
(let ((commit "c98d44f47cc88d19ff91ca3eefbd9719a8ace022")
(revision "1"))
@@ -17819,41 +17204,6 @@ implementations offer.")
(define-public cl-atomics
(sbcl-package->cl-source-package sbcl-atomics))
-(define-public sbcl-cl-mock
- ;; .asd version only got updated recently, despired the old GitHug "1.0.1" release.
- (let ((commit "7988dca2093358911b67597a2cd1570c785dfe76"))
- (package
- (name "sbcl-cl-mock")
- (version (git-version "1.0.1" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Ferada/cl-mock/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0f40wikcf783jx26ip0nnhwjjfjvjiw7njqsqrb6kaphc8bgw0i1"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("closer-mop" ,sbcl-closer-mop)
- ("trivia" ,sbcl-trivia)))
- (native-inputs
- `(("fiveam" ,sbcl-fiveam)))
- (home-page "https://github.com/Ferada/cl-mock")
- (synopsis "Mocking functions for Common Lisp testing")
- (description
- "This small library provides a way to replace the actual implementation
-of either regular or generic functions with mocks.")
- (license license:agpl3))))
-
-(define-public ecl-cl-mock
- (sbcl-package->ecl-package sbcl-cl-mock))
-
-(define-public cl-mock
- (sbcl-package->cl-source-package sbcl-cl-mock))
-
(define-public sbcl-cl-murmurhash
;; No release.
(let ((commit "5433f5e95f1cce63a81259a471150834c6a59364")
@@ -19231,3 +18581,70 @@ higher-level lispier interface.")
(define-public ecl-cl-charms
(sbcl-package->ecl-package sbcl-cl-charms))
+
+(define-public sbcl-clinenoise
+ (let ((commit "46e21f99d06a55d93eaa382cf652d55d457032ef")
+ (revision "1"))
+ (package
+ (name "sbcl-clinenoise")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jasom/clinenoise")
+ (commit commit)))
+ (file-name (git-file-name "clinenoise" version))
+ (sha256
+ (base32 "0ydlirfk4dbpqqjwwph99v5swcrhd8v9g8q24fvs35wn2vm08lh1"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cffi" ,sbcl-cffi)
+ ("split-sequence" ,sbcl-split-sequence)))
+ (home-page "https://github.com/jasom/clinenoise")
+ (synopsis "Port of linenoise to Common Lisp")
+ (description
+ "This package provides a trivial line-input library for VT-like
+terminals.")
+ (license license:bsd-2))))
+
+(define-public cl-clinenoise
+ (sbcl-package->cl-source-package sbcl-clinenoise))
+
+(define-public ecl-clinenoise
+ (sbcl-package->ecl-package sbcl-clinenoise))
+
+(define-public sbcl-cl-pass
+ (let ((commit "e58e97c0c0588dc742c061208afb9bc31e4dbd34")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-pass")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/cl-pass")
+ (commit commit)))
+ (file-name (git-file-name "cl-pass" version))
+ (sha256
+ (base32 "05qx4jrkxqbqi72cxgswbpnifbdvp9mh7apc7566v522899bh0hb"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("ironclad" ,sbcl-ironclad)
+ ("trivial-utf-8" ,sbcl-trivial-utf-8)
+ ("split-sequence" ,sbcl-split-sequence)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (home-page "https://github.com/eudoxia0/cl-pass")
+ (synopsis "Password hashing and verification library")
+ (description
+ "@code{cl-pass} is a password hashing and verification library.")
+ (license license:expat))))
+
+(define-public cl-pass
+ (sbcl-package->cl-source-package sbcl-cl-pass))
+
+(define-public ecl-cl-pass
+ (sbcl-package->ecl-package sbcl-cl-pass))