summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3a37f572cb..e434de477e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -235,9 +235,15 @@
;; ("cracklib" ,cracklib)
))
(arguments
- ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
- ;; isn't available.
- '(#:tests? #f))
+ '(;; Most users, such as `shadow', expect the headers to be under
+ ;; `security'.
+ #:configure-flags (list (string-append "--includedir="
+ (assoc-ref %outputs "out")
+ "/include/security"))
+
+ ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
+ ;; isn't available.
+ #:tests? #f))
(home-page "http://www.linux-pam.org/")
(synopsis "Pluggable authentication modules for Linux")
(description