summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 37db1e9055..a4639bdd59 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -327,14 +327,14 @@ It has been modified to remove all non-free binary blobs.")
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
(define-public linux-libre
- (make-linux-libre "4.8.7"
- "1jbwm131zv59iyr6qw7qcbcfz49qqb2hhx30230gb99flyc5h4hg"
+ (make-linux-libre "4.8.10"
+ "04kwarmpz5adz64wwy0xpwzxsri7jrjkhbmjlwxsac69x9a26bkl"
%intel-compatible-systems
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.31"
- "1s4xdllvxw02g4yqlafcacgsgdpxccf6dlqafpqffm873q1y9n4d"
+ (make-linux-libre "4.4.34"
+ "04ng40l2av34bcfwjs5vliv15f0m8bl0sfw08imspiplxvajd6ca"
%intel-compatible-systems
#:configuration-file kernel-config))
@@ -345,8 +345,8 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
;; Avoid rebuilding kernel variants when there is a minor version bump.
-(define %linux-libre-version "4.8.7")
-(define %linux-libre-hash "1jbwm131zv59iyr6qw7qcbcfz49qqb2hhx30230gb99flyc5h4hg")
+(define %linux-libre-version "4.8.10")
+(define %linux-libre-hash "04kwarmpz5adz64wwy0xpwzxsri7jrjkhbmjlwxsac69x9a26bkl")
(define-public linux-libre-arm-generic
(make-linux-libre %linux-libre-version
@@ -1683,7 +1683,8 @@ time.")
(("confdir = .*$")
"confdir = @sysconfdir@\n")
(("DEFAULT_SYS_DIR = @DEFAULT_SYS_DIR@")
- "DEFAULT_SYS_DIR = @sysconfdir@"))))))
+ "DEFAULT_SYS_DIR = @sysconfdir@"))))
+ (patches (search-patches "lvm2-static-link.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1738,6 +1739,22 @@ mapper. Kernel components are part of Linux-libre.")
;; Command-line tools are GPLv2.
(license (list license:gpl2 license:lgpl2.1))))
+(define-public lvm2-static
+ (package
+ (inherit lvm2)
+ (name "lvm2-static")
+
+ ;; Propagate udev because libdevmapper.a depends on libudev.
+ (inputs (alist-delete "udev" (package-inputs lvm2)))
+ (propagated-inputs `(("udev" ,eudev)))
+
+ (arguments
+ (substitute-keyword-arguments (package-arguments lvm2)
+ ((#:configure-flags flags '())
+ ;; LVM2 doesn't use Libtool, hence the custom option.
+ `(cons "--enable-static_link" ,flags))))
+ (synopsis "Logical volume management for Linux (statically linked)")))
+
(define-public wireless-tools
(package
(name "wireless-tools")
@@ -2647,7 +2664,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "4.8.3")
+ (version "4.8.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -2655,7 +2672,7 @@ and copy/paste text in the console and in xterm.")
"btrfs-progs-v" version ".tar.xz"))
(sha256
(base32
- "1wlflrygnpndppil9g12pk184f75g9qx1lkr0x1gijigglqhr9n1"))))
+ "1ib1ybpjhcymcycjiraz1vk01qlyvpwcg7mwfhmacdy3cvbfl9mz"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; static versions of binaries in "out" (~16MiB!)
@@ -3128,7 +3145,7 @@ developers.")
(string-append "PREFIX=" %output))
#:tests? #f)) ; no tests
(native-inputs
- `(("gnu-gettext" ,gnu-gettext)
+ `(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
`(("libdrm" ,libdrm)