summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm69
1 files changed, 61 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index efc7fb7b3f..f8bb6e2c1f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
@@ -511,16 +511,28 @@ slabtop, and skill.")
version ".tar.gz"))
(sha256
(base32
- "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))))
+ "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "MCONFIG.in"
+ (("INSTALL_SYMLINK = /bin/sh")
+ "INSTALL_SYMLINK = sh")))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo))) ; for the libext2fs Info manual
+ ("texinfo" ,texinfo))) ;for the libext2fs Info manual
(arguments
'(;; The 'blkid' command and library are already provided by util-linux,
;; which is the preferred source for them (see, e.g.,
;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b336339909c90559b7db40b455f172>.)
- #:configure-flags '("--disable-blkid")
+ #:configure-flags '("--disable-blkid"
+
+ ;; Install libext2fs et al.
+ "--enable-elf-shlibs")
+
+ #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))
#:phases (alist-cons-before
'configure 'patch-shells
@@ -532,7 +544,11 @@ slabtop, and skill.")
(substitute* (find-files "." "^Makefile.in$")
(("#!/bin/sh")
(string-append "#!" (which "sh")))))
- %standard-phases)
+ (alist-cons-after
+ 'install 'install-libs
+ (lambda _
+ (zero? (system* "make" "install-libs")))
+ %standard-phases))
;; FIXME: Tests work by comparing the stdout/stderr of programs, that
;; they fail because we get an extra line that says "Can't check if
@@ -579,6 +595,41 @@ from the e2fsprogs package. It is meant to be used in initrds.")
(home-page (package-home-page e2fsprogs))
(license (package-license e2fsprogs))))
+(define-public zerofree
+ (package
+ (name "zerofree")
+ (version "1.0.3")
+ (home-page "http://intgat.tigress.co.uk/rmy/uml/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page name "-" version
+ ".tgz"))
+ (sha256
+ (base32
+ "1xncw3dn2cp922ly42m96p6fh7jv8ysg6bwqbk5xvw701f3dmkrs"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (copy-file "zerofree"
+ (string-append bin "/zerofree"))
+ (chmod (string-append bin "/zerofree")
+ #o555)
+ #t))
+ (alist-delete 'configure %standard-phases))
+ #:tests? #f)) ;no tests
+ (inputs `(("libext2fs" ,e2fsprogs)))
+ (synopsis "Zero non-allocated regions in ext2/ext3/ext4 file systems")
+ (description
+ "The zerofree command scans the free blocks in an ext2 file system and
+fills any non-zero blocks with zeroes. This is a useful way to make disk
+images more compressible.")
+ (license gpl2)))
+
(define-public strace
(package
(name "strace")
@@ -1511,9 +1562,11 @@ mapper. Kernel components are part of Linux-libre.")
%standard-phases)
#:tests? #f))
(synopsis "Tools for manipulating Linux Wireless Extensions")
- (description "Wireless Tools are used to manipulate the Linux Wireless
-Extensions. The Wireless Extension is an interface allowing you to set
-Wireless LAN specific parameters and get the specific stats.")
+ (description "Wireless Tools are used to manipulate the now-deprecated
+Linux Wireless Extensions; consider using 'iw' instead. The Wireless
+Extension was an interface allowing you to set Wireless LAN specific
+parameters and get the specific stats. It is deprecated in favor the nl80211
+interface.")
(home-page "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html")
(license gpl2+)))