summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 669db96602..83761e5955 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2287,8 +2287,7 @@ module.")
(ice-9 ftw)
(srfi srfi-26))
- (let ((e2fsck (string-append (assoc-ref %build-inputs "e2fsprogs")
- "/sbin/e2fsck"))
+ (let ((e2fsck (search-input-file %build-inputs "/sbin/e2fsck"))
(bin (string-append (assoc-ref %outputs "out") "/sbin")))
(mkdir-p bin)
(with-directory-excursion bin