summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b79318f23a..8fe91b4e9f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -163,7 +163,11 @@
(format #t "enabling additional modules...~%")
(substitute* ".config"
(("^# CONFIG_CIFS.*$")
- "CONFIG_CIFS=m\n"))
+ "CONFIG_CIFS=m\n")
+ (("^# CONFIG_([[:graph:]]*)VIRTIO([[:graph:]]*) .*$"
+ _ before after)
+ (string-append "CONFIG_" before "VIRTIO"
+ after "=m\n")))
(zero? (system* "make" "oldconfig")))
;; Call the default `build' phase so `-j' is correctly